test content
What is the Arc Client?
Install Arc

[XBOX] Lost City of Omu - Launch Week Bugs

nitocris83nitocris83 Member, Cryptic Developer, Administrator Posts: 4,037 Community Manager
Hello everyone! Please use this thread to report all *new* bugs or issues you encounter after the release of M13 - Lost City of Omu. Please continue using the rest of the Xbox Bugs subforum to discuss bugs that existed prior to M13's launch.

NOTE: Please do not use this thread to discuss balance changes. This is for bugs only. Posts not relevant to this thread will be moved.


  • btexpress77#1109 btexpress77 Member Posts: 1 Arc User
    I can't put my equipment on my companions
  • highlandlaurahighlandlaura Member Posts: 1 Arc User
    Chultan tiger is bugged. Unable to equip rings or neck to it even after resetting Xbox
  • ennileahennileah Member Posts: 134 Arc User
    Yep my tiger too is bugged along with another from our alliance. Same issue, will slot runestones fine but wont accept any ring or neck piece at all
  • edf#3333 edf Member Posts: 1 New User
    I can’t place equipment on the chultan tiger. Let me say what a let down
  • ennileahennileah Member Posts: 134 Arc User
    So a bit if a discovery here, I made the tiger idle on my 1st loadout and chose my old companion there, went back to 2nd loadout and its now allowing me to equip rings and neck on that loadout only. it still wont allow me now to equip gear on the first loadout when i i make the tiger active again from idle slot. Also with this setup.. it seems to lock me out of moving to my 2nd loadout without making the tiger idle again
  • jslegge1901jslegge1901 Member Posts: 83 Arc User
    There is chatter everywhere, including my own personal experience of not being able to equip items to companions. My experience was specifically with the Chultan Hunter and the Owlbear Cub. Others are reporting issues with the Tiger and the Sellsword.

    It seems if you swap a companion, you will not be able to equip items to it.

  • nitocris83nitocris83 Member, Cryptic Developer, Administrator Posts: 4,037 Community Manager
    Hey everyone! We are aware of the issue with companions, specifically the Chultan Tiger. I will share any new information that I get.
  • toriofthehordetoriofthehorde Member Posts: 17 Arc User
    The chultan tiger will not allow you to put on rings or neck...
  • ennileahennileah Member Posts: 134 Arc User
    > @kreatyve said:
    > The chultan tiger will not allow you to put on rings or neck...
    > Make it idle with nothing in the companion slot. Then put it back in the active slot again. That should fix it.

    Wish mine would allow me to have on both loadouts.. its still locking me out of swapping loadouts when i try to have it on more than one setup!
  • ennileahennileah Member Posts: 134 Arc User
    And after 3 times of making idle...swapping out.. trying again its finally accepted the tiger and all gears on bibo loadouts.. wow.. Mission!!!
  • fluffy6977fluffy6977 Member Posts: 291 Arc User
    edited May 2018
    ***I have already logged a support ticket, this is just a bug report***

    Logged into my CW and swapped loadouts to decide which one I wanted to respec. Noticed that my Mythic Sigil of the Controller did not show and instead a small icon I have not seen before said that the Lantern of Revelations the loadout expected was missing from my inventory and a small pop up said the sigil of the controller was returned to my inventory. I thought nothing of it until I swapped back to the other loadout and got an icon saying the expected Heart of the Blue Dragon was missing from my inventory. Checked the character bank and saw both artifacts in the bank, still with the little icon indicating that they were matched to a loadout. Triple checked my inventory, then had my buddy check through it, the Sigil is completely missing. Verified the Sigil was missing by picking up another one out of the Claims Merchant, which worked, so the artifact is in fact gone.


    Support is unable to find any record of that character having ever had that artifact prior to the green one I pulled out yesterday to verify with. This isn't possible, since this is the character that initially earned the artifact from the vault of the nine years ago. Still going to attempt a recovery with them, but since I can't prove I had it and the game apparently deleted it from association with the character, pretty sure I'm out of luck now..
    *** Collections tab for the Control Wizard also shows no Sigil of the Controller unlocked above green.

    ***Update 2***

    Support is unable to find any association of that artifact on any character that has it equipped currently. The only association they can find is the one sitting in a personal vault for another character. I have supplied them with screenshots of the 7 Sigils of the Controller currently equipped on various characters that they cannot see. Tomorrow I will attempt to reproduce the error on an alt with an unleveled version of the artifact.

    ***Final Update***

    After escalating a second time, Support says there is record of a previous character of the same name on the account and that character was deleted. They seem to have decided that the Mythic level Sigil was on that character and that the current character has never had one. Since I don't have any way to prove that I never deleted my character they say there is nothing else they can do. No idea what happened there..

    Regarding the Sigils they could not see on other characters, once I un-equipped and re-equipped the Sigil they could see them. No idea what's going on there either..

    Support has closed the ticket.
    Post edited by fluffy6977 on
  • xxdiabloxx#5183 xxdiabloxx Member Posts: 6 Arc User
    edited April 2018
    hi guys, My friend however find a temp fix for those that are still having trouble, remove your ALL companions from ur active slots, then while in game hard reset your xbox.

    while in game, Hold the Power down until xbox one is off.
    unplug ur xbox from wall for about 1 min.
    then just plug back in and play and then reactivate ur companions.
  • xxdiabloxx#5183 xxdiabloxx Member Posts: 6 Arc User
    > @kreatyve said:

    > You don't even have to reset the Xbox. Just empty the companion slot of the bugged companion and then reactivate the companion. I posted that above.

    I tried that and it did not work for me! then this happened some of the other companions stop working, I couldn't equipped necks, rings or belts.... so for me it made it worst. I thought I let you you know!
  • mich840#7745 mich840 Member Posts: 3 Arc User
    Hello perfect world, I'm having trouble getting to omu on my hr. I have the chult campaign completed on my dc, but not on my hr. I wanted to know if this was a glitch or intentional (to restrict travel to omu if you don't have the main tree for chult unlocked.)
  • xogoddessofwarxogoddessofwar Member Posts: 9 Arc User
    I'm unable to switch loadouts after the update. I keep getting an error message about gear not being there, but i haven't changed anything.
  • shazza53shazza53 Member Posts: 147 Arc User
    Maybe this wasn’t intended to be implemented yet ... but Masterwork Recipes using allosaur fangs have not been updated. And, presumably the allosaur fangs drop rate has also not been increased.
  • devildog0010#3243 devildog0010 Member Posts: 1 New User
    Guild alliance: when inspecting members from the alliance page, the guild menu is stuck on top, and underneath is the character, whom you are unable to see.
  • kazumaikazumai Member Posts: 1 New User
    I’ve heard a few friends say that they are receiving no sound output at all. They checked game and tv settings, and nothing.
  • geminisky59#9345 geminisky59 Member Posts: 68 Arc User
    this bug is related to gwf skills. in the house of crocidile instance I am unable to go into unstoppable mode after patch. this was a bug in previous mods but now seems to gave been reintroduced.
  • ashwilliowbrook#2249 ashwilliowbrook Member Posts: 26 Arc User
    For some reason I can’t transmute my Fured Kuino of the Bear using the gear from the Underdark vendor. It will let me use Martyrs Plackart and Executioners Black Atire but not the Underdark stuff. Another guild member reported the same problem.
  • zephyriahzephyriah Member, NW M9 Playtest Posts: 2,980 Arc User

    Hello perfect world, I'm having trouble getting to omu on my hr. I have the chult campaign completed on my dc, but not on my hr. I wanted to know if this was a glitch or intentional (to restrict travel to omu if you don't have the main tree for chult unlocked.)

    I'd say intentional. You cannot go to Omu except by going through Chult. If you look at the campaign tab, you can see the Omu campaign is simply an add-on to the top of Chult one.

    Second, the quest to unlock Chult comes from Celeste who you need to rescue in the Chult campaign to enable her as a quest giver for Chult and Omu task. I can't think of a way to get to Omu without her. So, it might be possible to do just enough of the Chult campaign to save Celeste, but that is only a guess. You could always try doing it Chult a bit a time and returning to Celeste to see if/when she will send you to Omu.
  • spelldazerspelldazer Member Posts: 311 Arc User
    Inventory overflow is bugged again. I have to manually move items into open slots in my bags. Clicking the joystick to automatically do it returns an "inventory full" kind of error message, even though bags are not full.
Sign In or Register to comment.