test content
What is the Arc Client?
Install Arc

[XBOX] Lost City of Omu - Launch Week Bugs



  • fightdawalrus#5058 fightdawalrus Member Posts: 114 Arc User
    > @xxdiabloxx#5183 said:
    > hi guys, My friend however find a temp fix for those that are still having trouble, remove your ALL companions from ur active slots, then while in game hard reset your xbox.


    > while in game, Hold the Power down until xbox one is off.

    > unplug ur xbox from wall for about 1 min.

    > then just plug back in and play and then reactivate ur companions.

    Are you trolling? All that nonsense about turning off your xbox makes it seem that way.

    There's a few bugs. Companions CONSTANTLY dying and getting unsummoned (especially in T9G), The Ghost quest will put you in a perma combat and make you fail the quest, Hunt drop rates being a horrible (at least I hope its a bug),etc.
  • mabe#0605 mabe Member Posts: 4 Arc User
    Inactivate the tiger (or any companion that's glitching) to an EMPTY inactive companion slot, then reactivate him and put on equipment as normal. Will not work if you just
  • dowden#4495 dowden Member Posts: 1 Arc User
    I am having the companion bug and i cannot change loadouts also.. anybody find even a temp fix for this..
  • gbtroisgbtrois Member Posts: 1 Arc User
    On my Fire Archon, I am unable to equip the slot gear : with ring and talisman
    I clicked equip, but nothing actually equipped, and I got no error message.
  • spelldazerspelldazer Member Posts: 311 Arc User
    When pulled into a dungeon, summoned companion is missing a lot of the times
  • shazza53shazza53 Member Posts: 147 Arc User
    edited April 2018
    May we please get an update on the plans to fix Masterwork?

    The Allosaur fang drop rate needs to be increased, along with updates to several recipes using allosaur fangs. Less critical is the proper placement of the new Masterwork Resources in he Auction House. They are currently in Miscellaneous instead of Professions.
  • mich840#7745 mich840 Member Posts: 3 Arc User
    To fix the companion bug, not being able to equip the gear, you need to make it idle with an empty companion slot. Ex. Press Y or triangle, click "make idle", and choose an empty position, then make the companion active. Then BOOM you can equip gear to it.
  • draconislupusdraconislupus Member Posts: 205 Arc User
    Sorting the guild vaults after adding new items so that they stack with existing items hard crashes the game. It has done it 3 times to me. Did it with lockboxes, marks and enchanting stones, and shards. I tried sorting once before adding items, no crash. I tried sorting once after taking an item out and putting it back in a new spot, no crash. I tried sorting after only removing part of an existing stack, no crash. So apparently it only happens when new items are put in the vault and then it is sorted.
  • akmid#5759 akmid Member Posts: 2 Arc User
    I am also having the companion bug. But it didn't start for me till I got the Ghost companion and moved her from idle to active. Also has Harper Sudbury been moved from the Hall of Justice? Because he is not there for me or my husband on ANY of our characters (Hubby plays under gamer tag CentralSteak128 and I under MunkyTrouble with our Xbox1) We cant complete the Some Good Advice quest you get at level 70 because of it, which keeps you from finishing Epic Adventuring, and we just got our third characters to 70 the other day. Also we do all our questing together and when we went through Whispering Caverns everything completed and finished for me as it was supposed to but for some reason The Illithid Enclave quest fanished from his log, we went back to see if it had been abandoned by accident and its just .. gone. He can't pick it up again or anything. Any ideas on when or how all this can be fixed?
  • ileftcaps0nileftcaps0n Member Posts: 1 Arc User
    I've been locked out of my loadouts as well, but I think it was because of a power point token. My character is a paladin with two completely different builds, and after I used a power point on a power for one loadout and then a different power on my other loadout, I keep getting a message saying "unable to equip some items from the loadout" when I try to swap them out.
    None of my gear changed between the two, but applied everything to all loadouts to make sure - didn't work.
    Thought it might have something to do with my companions, since I couldn't equip anything on my energon, so I tried the fixes for them, mentioned above, and it didn't work.

    I'm kinda useless for dungeons/skirmishes until this gets a fix.

    I'm still pretty new at this, so if any workarounds are found, I'm all ears.
  • ashwilliowbrook#2249 ashwilliowbrook Member Posts: 26 Arc User
    Any word on the transmute situation @nitocris83 ? It seems we are unable to use the gear from the Underdark vendor to transmute any of the new hunt gear.
  • nitocris83nitocris83 Member, Cryptic Developer, Administrator Posts: 4,004 Community Manager
    Hi everyone! I am follow up on the additional reports that came in after launch day and will provide any updates I hear.
  • mahburgmahburg Member Posts: 598 Arc User
    I started a new thread in the bug forum on artifact gear upgrading we no longer get 80% value its more like 20% now.
    Something wrong somewhere unless it is intentional?
  • revidcargianrevidcargian Member Posts: 3 Arc User
    While watching my girlfriend play on her account, I've noticed that, since the Omu update, some collectibles in Soshenstar River have become unavailable in various ways. I had already obtained these on my own account prior to the Omu launch, and can only test one of the collectibles myself.

    The Sahha ball located around - 899,1262 is unable to be picked up. The ball itself is visible, and sparkles as if it can be picked up, but the prompt to obtain the ball never appears. This makes both the in-game and Xbox achievement related to the Sahha balls impossible to obtain for those who don't already have this ball. As the other 4 balls are obtained on my and my girlfriends' account, I'm unable to test this further. This issue was, however, mentioned by another user on a post made about a week ago.

    In addition to this Sahha Ball, the scrying orb located just south of this ball is no longer even visible. Originally, the scrying orb could be seen and easily reached by simply walking between a tree and the ruined temple just north of the tree. Now, however, there is a pile of debris covering where the scrying orb is/was, making it impossible to interact with.

    I have a small set of photos on Imgur to document these issues for anyone else/the dev team to look over. (Apparently I'm not allowed to post links since my account here is too new or something? I'll try and post proof of all this when I can.)

    While I had already previously collected/interacted with these objects, we both primarily play games to complete them as much as possible, so it's disappointing that my girlfriend and others may not be able to complete these tasks/achievements going forward. I'm unsure if the scrying orb has moved, but I've seen no information mentioning this.

    If anyone has any suggestions, or if the Devs can be made aware of the issue, it would be greatly appreciated!
  • trevor#8542 trevor Member Posts: 119 Arc User
    ennileah said:

    And after 3 times of making idle...swapping out.. trying again its finally accepted the tiger and all gears on bibo loadouts.. wow.. Mission!!!

    I have figured out the same workaround for the companions but in order for it to work is you have to not only make it idle you have to put it into a empty idle slot switching it with another doesnt work or at least it didnt for me.
  • linliwei#4203 linliwei Member Posts: 7 Arc User
    Hello, I am a player from China. I encountered the bug of my Companion in the game, which made me unable to continue the game.

    My companions will disappear after the battle, almost always. Look at my picture, my partner disappears after the battle, and then the character goes into combat, and I'm actually out of combat. After each battle you need to reactivate your partner. As you can see in the picture, after using loadout, there will be a false or false partner, and there is no peer in my peer field.

    We look forward to solving this problem as soon as possible. Thank you very much. :)

  • vladdracula777vladdracula777 Member Posts: 7 Arc User
    edited May 2018
    I have the same issues with the same ball and scrying stone, ever since the launch of omu I have been seeing more and bugs in the game which is unfair to the people cause they can't get there achievements and arc doesn't seem to care.
  • stuntmanracerstuntmanracer Member Posts: 1 Arc User
    One of the mastercraft resources nodes in hotenow is not giving resources to the player at location (2159, 2310)

    >obtain a resource scroll from the stronghold vendor for hotenow

    >travel to hotenow

    >open up the resource scroll and go to the resource node located at (2159, 2310)

    >interact with the node and note how much alum, sal almmonic, and nitre you currently have.

    >press A to collect the node and note nothing happens, so press X to collect the resources instead and note that an item recieved icon did not appear on the right side of the screen

    >check how much nitre, alum, and sal almmonic you have and see it didnt change.

    I farmed 180 scrolls before i noticed this node was broken on double professions with the explorers boon.
  • rocdoc1807#1690 rocdoc1807 Member Posts: 5 Arc User
    Once again I am showing that I have 163 of 175 lost Idols in my OMU adventures slot in the campaign window and am receiving error messages that I have reached my limit on lost idols for the week. This is the second time this has happened to me and I am behind my guildmates in progression because of it. Please fix this and complete the campaign for me so that I may catch up.
  • trevor#8542 trevor Member Posts: 119 Arc User

    Once again I am showing that I have 163 of 175 lost Idols in my OMU adventures slot in the campaign window and am receiving error messages that I have reached my limit on lost idols for the week. This is the second time this has happened to me and I am behind my guildmates in progression because of it. Please fix this and complete the campaign for me so that I may catch up.

    even while is says that it still gives you the idols until you are capped happens to me every week
  • rainroneyrainroney Member Posts: 1 Arc User

    First bug: If I dodge or get push back with my Tricksrer Rouge and I use in the same moment Impossible to Catch, the buff will not work.
    Second Bug: Fighting against is a torture. Because if I get stunned, my character is usually stucked on the position where the debuff ends. My only chance to move away is to dodge, kill my self or say I am stucked.
  • ellic#3185 ellic Member Posts: 1 Arc User
    I am having a problem. I am doing the Dark Tidings quest to get to Chult on my HR. I get can do all the quest but when I get to last the part, the part with the bost cut scene. It goes to the load screen instead of going to Chult it kicks me out of the game completely . When I finally able to log back in I am in the Protector Enclave.
  • illussionillussion Member Posts: 4 Arc User
    This bug still hasn't been fixed. Still issues
Sign In or Register to comment.