test content
What is the Arc Client?
Install Arc

Random crashes

I recently installed (clean) Windows 10 version 1909. Game started crashing randomly ever since. Earlier when I had Win7 there were no errors ever.

I overwrote WHQL drivers from OEM website as suggested by support. However the game crashed again. I sent DxDiag & Error screenshots to support, and I got this reply:

"
Based on the information you supplied it looks like the issue is the result of a bug and while I don't have a fix for you, I'll gather the details that you've given to me and pass them on for further investigation. Something else you may want to do is post about this issue on the official bug reports forum: https://www.arcgames.com/en/forums/startrekonline#/categories/gameplay-bug-reports

Even though the developers and QA team may not reply, they will see it there and hopefully look into the issue.
"

So here I am.

Comments

  • allurahunterallurahunter Member Posts: 18 Arc User
    I'm having the same problem while trying to start the game.
  • raijinmeister#1931 raijinmeister Member Posts: 150 Arc User
    I recently installed (clean) Windows 10 version 1909. Game started crashing randomly ever since. Earlier when I had Win7 there were no errors ever.

    I overwrote WHQL drivers from OEM website as suggested by support. However the game crashed again. I sent DxDiag & Error screenshots to support, and I got this reply:

    "
    Based on the information you supplied it looks like the issue is the result of a bug and while I don't have a fix for you, I'll gather the details that you've given to me and pass them on for further investigation. Something else you may want to do is post about this issue on the official bug reports forum: https://www.arcgames.com/en/forums/startrekonline#/categories/gameplay-bug-reports

    Even though the developers and QA team may not reply, they will see it there and hopefully look into the issue.
    "

    So here I am.

    Maybe you already did that but have you tried set the game to run in compatibility mode to the Win 7 service pack?
  • bongboss#7079 bongboss Member Posts: 5 Arc User

    Maybe you already did that but have you tried set the game to run in compatibility mode to the Win 7 service pack?

    I play with Steam. How do I do that?
  • bongboss#7079 bongboss Member Posts: 5 Arc User

    Maybe you already did that but have you tried set the game to run in compatibility mode to the Win 7 service pack?

    Got it. Tried in compatibility mode for Win7. Also tried to run it as administrator. It actually made matter worse. Now game crashes as soon as I start any mission.
  • sthe91sthe91 Member Posts: 3,540 Arc User
    Have you turned off On-Demand Patching in the Options section of the Star Trek Online launcher and then done a Force-Verify? Thanks. :)
    Where there is a Will, there is a Way.
  • bongboss#7079 bongboss Member Posts: 5 Arc User
    sthe91 wrote: »
    Have you turned off On-Demand Patching in the Options section of the Star Trek Online launcher and then done a Force-Verify? Thanks. :)

    Well well well! This seems to have fixed the crashing issue completely. No crash in the last 2 days.

    Thank you so much! :smile:
  • sthe91sthe91 Member Posts: 3,540 Arc User
    edited April 2020
    sthe91 wrote: »
    Have you turned off On-Demand Patching in the Options section of the Star Trek Online launcher and then done a Force-Verify? Thanks. :)

    Well well well! This seems to have fixed the crashing issue completely. No crash in the last 2 days.

    Thank you so much! :smile:

    You are welcome.
    Where there is a Will, there is a Way.
Sign In or Register to comment.