test content
What is the Arc Client?
Install Arc

Vanguard movement speed bug(?) plz help

tardbathtardbath Member Posts: 80 Arc User
edited November 2021 in The Guard Barracks
The movement speed bonus that is granted from azure/brutal enchants and the SH guild boon has a bug on my toon(if it's only me that has this)!

Pressing TAB or even moving and pressing the shield button makes the toon lose its bonus speed (azures/brutal/sh speed boon) when the indication "IMMUNE" is displayed on my screen. Removing a gear piece or the SH boon and re applying fixes the issue but this also happens in combat!

Comments

  • modlesiemodlesie Member Posts: 186 Arc User
    edited November 2021
    + 1 to this, and this is not only Vanguard but also dreadnought

    When you rise your shield up your movement speed is reduced + movement speed is wrongly calculated

    Look at this:



    So basicly my movement speed is 42,5%?

    -5x azure =25%
    -guild boon 10%
    -boons from campaing 12,5%
    -boons from insignia 10%

    total movement speed should be 57,5% am i right? What's more, rise your shield and BANG 42,5%, this is serious issue.

    Lets go further, when you remove all equipment with azures you have.... 52,5% xDDD LOOOL, what a MESS, total mess

    Gear up again and you have 77,5% o_O

    + boon from class features and we have 97,5%

    Should i tell you, that DC with 65% movement speed is running faster than my Fighter with 97,5% movement speed?;)

    This is completely wrong and should be fixed as soon as possible.

    I know there is not much Fighters around but at least let them work as intended

    @nitocris83
Sign In or Register to comment.