test content
What is the Arc Client?
Install Arc

Storm King's Thunder Bugs & Issues



  • Options
    magdar#9208 magdar Member Posts: 3 Arc User

    When I try to go to Bryn Shandar Epicenter to complete Shrine of Mielikki quest it kicks me out and then doesn't let me back on. Says timed out of game servers. To get back in the game I have to shutdown and left it off for about 10 minutes to get back on, but the game locks if I try again to go the Bryn Shandar Epicenter.

    The new update fixed it. Thanks!
  • Options
    sirstrafe#9889 sirstrafe Member Posts: 3 Arc User
    Storm king campaign bug. I literally can not continue my campaign due to deleting a quest that would log me out everytime I tried to go to the epicenter.
  • Options
    dlboldt#8207 dlboldt Member Posts: 2 Arc User
    Storm King campaign bug. I couldnt get to Bryn Shandar Epicenter. It would log me out saying it couldnt reach the character server. I deleted the quest, now I dont have any available quests in the campaign and cannot continue.
  • Options
    clovenbobcatclovenbobcat Member Posts: 1 Arc User
    Storm King's Thunder campaign bug. I'm receiving the message "obtain or complete the quest" from npcs of Bryn Shander. I cannot continue the campaign due to deleting the quest Shrine of Mielikki, which I tried to complete, but as soon as I went to Bryn Shander Epicenter it gave me "Server Not Responding". Now I'm stuck, please help me (help us). Thanks
  • Options
    zorro1267#1300 zorro1267 Member Posts: 7 Arc User
    Since I can not start a new thread yet, I will post this here. It seems as though the trickster rogue feat shadow of demise is no longer working as described. It is supposed to prevent stealth loss when taking damage, but it doesn't do that anymore. Was this one of those unannounced nerfs? It seems pretty hard to "accidentally" disable shadow of demise.
  • Options
    zakudasdzakudasd Member Posts: 3 Arc User
    the past few days the game has been crazy laggy for me. i know its not my internet so i dont know whats going on... anyone else having this issue??
  • Options
    sn4k3pli5k1nsn4k3pli5k1n Member Posts: 1 Arc User
    since the launch of the module the armour enchantments for several of my characters have stopped working, any advice on how to fix?
  • Options
    balltillifall88balltillifall88 Member Posts: 9 Arc User

    I have 2.

    Firstly, i am a scourge warlock, and have the prince of hell stat feature. using the artifact class feature, with the new update, should raise my damage resistance by 5%, and it doesnt show the change, if it is even happing, on my stats. i have unequiped my grimoire and re-equiped and damage resistance does not change. i even paid 5000 AD to switch to a different artifact class power and then 5000 AD to switch back, thinking that might trigger it, and it still isnt showing the 5% damage resistance on my stats page.

    secondly, the moonbear still has no insignia bonus. i was hoping the update would fix that and it didnt. its really annoying that the only 3 insignia mount i even have doesnt even have an insignia bonus power. whats up with that?

    oh, and p.s.

    the original artifact class power was supposed to raise the defense rating by 5% and it was changed to raise actual damage resistance by 5%, which it isnt saying it is.

    anybody on here know anything about this yet? what makes it worse is that the other cass feature that i use isnt even unlocked on my artifact grimoire. if it was at least i could switch to it and make use of it until i figure it out...
  • Options
    bigdog131982#8331 bigdog131982 Member Posts: 4 Arc User
    Does anyone look at this forum board. My issue still isn't resolved, and I am getting really irritated by it.
  • Options
    thedramacusthedramacus Member Posts: 83 Arc User
    On the quests where you have to lure out the animals in the town and the one where you torch the totems to fight barbarians is seems that if someone dies you cannot activate that point. I sat at one for 5-10 min to see if it would reset itself. With as fast as the enemies respawn you would hope it would reset itself in that amount of time. If anyone has this its easy to get around switching instances.
    Dramacus 3.1 SW, Raven 2.9 HR, Aurora Shadowbain 2.7 GF, Mirduatas Vras 2.5 DC
    Si Vis Pacem 2.5 DC, Jade Shadowbain 2.4 CW, Para Bellum 1.5 GWF, President Not Sure lvl 69 OP
    Faith Shadowbain lvl 69 DC, Toof Fairy lvl 68 GWF, Arnie Shadowbain lvl 63 GF

    Your Credit Card Has Been Declined
  • Options
    nealbeatnealbeat Member, NW M9 Playtest Posts: 41 Arc User

    Since the update, my Guardian Fighter seems to get aggro/combat stance randomly without any enemies near. Notice it right after clearing a room or area, but it prevents me from going though a door, interacting with chests, nodes, or objectives so it is really annoying - almost unplayable.

    Sometimes after clearing a room I keep aggro for waaaaay too long, but other times seems to be ok, but a few seconds after the room is cleared, suddenly without any enemies - I go into combat stance.

    BTW, I appreciate ID Scrolls stacking to 999 and the character select screen seems to always go back to the character just on instead of 2 characters ago... wish everything stacked to 999, but ID scrolls is a nice start to quality of life improvements to the bag space issues. Nice work.

    I noticed it happens when i have Knights Valor active, if i deactivate it i can interact with doors and chest

  • Options
    spacequeen#6705 spacequeen Member Posts: 21 Arc User
    I cant finish the new quests . particularly the great deeds one. Honestly think they are bugged , i started a thread explaining it further in the bugs forum
  • Options
    My Epic mount has been running at 80%. I checked the menu & it says it is at 110% but it is not. Also the entry animation is of a 80% or less mount. My mount use to appear with a bolt of light, now it appears in a puff of smoke.
  • Options
    chiroz#4770 chiroz Member Posts: 1 Arc User
    I have been having the same shrine bug issue. i tried to sign post out after obtaining the herb to heal artimus and got disconnected. I kept getting disconnected trying to enter the shrine. i abandoned the quest like the game master suggested and now for the past three week my cleric cannot obtain ANY quests to further the story line. I have 3 other characters in FBI and am really pissed and disappointed because I wont be able to get into FBI with my cleric EVER and if they fix my character I wont be in FBI until December at least.

    After several tickets the Game master sent me here. Yes, I deleted the game three times reinstalled and still no quests available.
  • Options
    goldbear#0972 goldbear Member Posts: 1 New User
    Am I only person with problem of finishing the "Vault of Nine" quest and when told to goto the claims agent to get the sigil for your class it only offers me the sigil I got for my first toon??? Meaning my first toon was a trixter rogue and he got his proper sigil but toons I have made after him only offer them the sigil for the trixter rogue. I would post this in the main forums but for some reason am on probation for being new but have had an arc acct. for long time now. But if someone could please help me with this would be greatly appreciated thank you. :/
  • Options
    ecrana#2080 ecrana Member Posts: 1,654 Arc User
    You have to do Vault of the Nine for each class separately. If you only completed the quest on your TR you only have access to the TR sigil. If you want the DC sigil, you have to run Vault of the Nine using a Cleric, etc.
  • Options
    ltsmithnekoltsmithneko Member Posts: 1,578 Arc User
    Cold Run HE's tend not to give Great Success even if you do most of the work during the HE's, might need to be checked.
  • Options
    jgwilsonjgwilson Member Posts: 9 Arc User
    Still Can't progress in Storm King on XBOX - been one month since first report. Started with bugged initial shrine quest. had to delete quest, now can't progress! Please fix.. Support is horrible and won't add a quest .
  • Options
    silverwolf#7884 silverwolf Member Posts: 187 Arc User
    I have the Alchemy profession at level 20. The Rank 20 Experimentation task is available but the Rank 20 Alchemical Research is now missing. I noticed that the Rank 7 Alchemical Research task has re-appeared (obviously I've already previously completed that to get upto Rank 20).

    When the latest fix patch was applied (Version: NW.65.20160906b.18) I was already at Rank 20 Alchemy. I suspect that the bug affected the current Alchemy level and didn't target level 20 specifically.

    I'd rather not have to perform the Rank 20 Experimentation task multiple times to slowly work up the ranks again; please address this issue in a fix-patch.

  • Options
    meyamocarmen#4105 meyamocarmen Member Posts: 1 Arc User
    I was sent here after filing support ticket but I think this is a bug...I have no quests for the Storm King Campaign, I have searched all over Bryn Shander - nothing! I abandoned a quest before and now I cannot find where to get more quest - bad thing is all the Zen I have spent on lockboxes to only get Ostorian Relics that I cannot use because I cannot progress in the campaign. I am at a loss and the support ticket I submitted just suggest I come here because we are responsible for finding our own way in the game - so sad please I need help! :(
  • Options
    zackattackzackattack Member Posts: 9 Arc User
    On rare instances the Heroic Encounter "Frost Giant Excavation" (Bryn Shaner) never re-spawns the Giants to complete the encounter.
  • Options
    zackattackzackattack Member Posts: 9 Arc User
    The following Achievements in the Journal can no longer be completed due to content being removed from the game.

    1) Call of the Chasm
    2)Call of the Chasm (Epic)
    3)Dread Vault (Epic)
    4)Lair of Lostmauth - not the epic version
    5)Lair of the Mad dragon (Epic)
    6)Throne of Idris
    7)Throne of Idris (Epic)

    There are other Dungeons that you can not complete that are in the Journal. If I could get a confirmation that they are bringing these versions of the dungeons back that would be awesome. If however they are not coming back, Could we get an auto completion or removal of the journal entrys- Thanks
  • Options
    jgwilsonjgwilson Member Posts: 9 Arc User
    I still can not progress through Storm King content after abandoning the initial glitched Shrine of Mielikki quest. I could never again pick it up, nor any other new quest except the weekly in Bryn Shandar. Support will not help and it seems this show-stopping bug has no priority, nor a workaround. It's been months....and no fix? Can't support re-assign the quest?
  • Options
    lakotacrowlakotacrow Member Posts: 11 Arc User
    bepy1109 said:

    is all people having a problem with praying to the diety and not recieving rough astral diamonds since the last update??? on all 3 of my characters since the update

    I am, my hubby is... invoking = No Rough AD. You are not alone in this. It's disappointing. Once we do the first one of the day and get that ardent coin, we pretty much don't care if we invoke any more during gameplay. No need to waste time with something broken. Hopefully they will fix this problem very soon.

    Good luck to you.
  • Options
    zebularzebular Member, Neverwinter Moderator, NW M9 Playtest Posts: 15,270 Community Moderator
    edited January 2017

    bepy1109 said:

    is all people having a problem with praying to the diety and not recieving rough astral diamonds since the last update??? on all 3 of my characters since the update

    I am, my hubby is... invoking = No Rough AD. You are not alone in this. It's disappointing. Once we do the first one of the day and get that ardent coin, we pretty much don't care if we invoke any more during gameplay. No need to waste time with something broken. Hopefully they will fix this problem very soon.

    Good luck to you.
    Again, Invocation no longer gives Rough AD directly. This change has been in effect on the PC since August 15th 2016, and arrived to the XBOX and PS4 with the Storm King's Thunder update on October 18th in 2016.

    You can read more about this change to Invocation here, here, and here (as well as a few other threads here and there). I'll sum it up with a couple quotes though.

    Here is a rundown of the change:
    • Invocation now gives a Rough AD bonus instead of granting Rough AD directly. The bonus Rough AD awarded is moderately larger than what was previously granted as straight Rough AD. In general, Invoking while playing other Rough AD generating activities will see a reasonable increase in AD earned, while Invoking only will see a drastic decrease.
    Also, here's some more clarification from the Devs when this hit the PC regarding the Invocation change:
    Some clarifications about the Invocation changes:
    • There is no ""expiration"" of the bonus. It won't ever go away. As long as you are actively playing the character, the new system should not leave you any worse off.
    • In fact, the new system leaves you better off (again, if you are playing the character) by about +20%, because it just gives you that much more AD (at L70 -- slight variations at lower levels, just due to rounding).
    • There is supposed to be a UI treatment that makes this all clear. Looks like that isn't in yet :(. But it basically looks like a glory boost, if you've ever used one of those. It's a buff icon that tells you how many more points of +50% earn rate you have left.
    • There is a cap on the total boost value you can get (all numerics in any game need some kind of cap, computers don't like infinities), but it's super-big. It's set to 100,000 AD, which is about a month's worth of boost. So you could invoke all day every day for a month (ok, 27 days to be precise) and still not lose a thing (again, in fact you get +20%). Past a month, and you'd hit the cap if you invoked the full amount every day that month but never played anything that earned you AD.
    • Characters that you never play with -- only invoke -- are the only ones that lose out. Which was the intention: more rewards for playing, less for characters you don't play.
    The reason we made this change was because was saw that Invocation was the largest source of AD that could be generated by not actually playing the game, this is not good. It was very apparent when comparing the PC numbers with what was happening on Xbox, VERY different playstyles but the vast difference between the two groups suggested this was a problem area.

    The change we made will actually increase the amount of AD you would earn if combined with actual gameplay. You can even bank it for a week and play all on the weekend, you just have to do something to actually earn that AD now instead of having a bot army.

    Just to confirm, there is not reset time on the bonus AD, there is a limit that can be stored which should not be able to be hit with a week of only invoking or more. Again, if you play ""normally"" you should be able to claim more AD from this than you would have previously. It really should only affect characters who ONLY invoked and did nothing else. There will be an minor UI update to make this change more transparent to the user later on and planned for the Module 10 launch.
    Please do refrain from making bug report threads and reports on this, as no longer directly gaining Rough Astral Diamonds from Invocation is not a bug. Thanks!

  • Options
    yamayamayaamaayamayamayaamaa Member Posts: 27 Arc User
    I had 9+ Ostorian Chests from fangbreaker in my inventory and they were all removed after the update, how do I get them back?
    «‘-•·÷·- ¥ámá -·÷·•-`»

  • Options
    zebularzebular Member, Neverwinter Moderator, NW M9 Playtest Posts: 15,270 Community Moderator

    I had 9+ Ostorian Chests from fangbreaker in my inventory and they were all removed after the update, how do I get them back?

    They're not in your new "useful items" tab?
  • Options
    nigglenogglenigglenoggle Member Posts: 8 Arc User
    What is going on with hunter plant growth power? It ticks damage liek it is supposed to bow, however, there is a TWO SECOND delay between activation of the power and the first damage tick. no?????????? why is this? By the time it ticks twice most mobs are dead and we become useless. We are primarily meant as a strong aoe dps imo. yes it does root the enemies still as stated until 500% weapon damage is taken and it does tick four times. But the delay between activation and damage is terrible. please fix this, four ticks, starting immediately, not delayed.. Things die too quick now for it to even tick four counts of damage so its become irrelevant to an extent which is unreal cuz this is truly our only reliable high dps power. please on behalf of all us hr that are playing on Xbox right now wondering why the heck this is happening, fixxxxxx it. you're making me wanna quit
  • Options
    armadeonxarmadeonx Member Posts: 4,952 Arc User
    For the last few days (since 10.5) Cleric targeting for AoE encounters and Dailies doesn't work properly, it usually aims well past enemies. I checked in Alliance chat and others are having the same issue and say it does the same for HR encounters.
    Please Do Not Feed The Trolls

    Xael De Armadeon: DC
    Xane De Armadeon: CW
    Zen De Armadeon: OP
    Zohar De Armadeon: TR
    Chrion De Armadeon: SW
    Gosti Big Belly: GWF
    Barney McRustbucket: GF
    Lt. Thackeray: HR
    Lucius De Armadeon: BD

    Member of Casual Dailies - XBox
  • Options
    ahrmonahrmon Member Posts: 15 Arc User
    Legendary Dragon keys are being consumed BEFORE the Kessels/Mystic Dragon keys FFS. I mean, you CANNOT make this HAMSTER up, folks.
This discussion has been closed.