test content
What is the Arc Client?
Install Arc

Black Screen on Launch

Hello,

For the past couple of weeks now, everytime I open the Game Launcher and click 'Engage', the screen goes black and stops responding.
I then have to Ctrl+Alt+Del, End Task and open it again, then it works the second time.

Is this a known issue, and are there any suggestions as to how to resolve it?

Thanks in advance...

Comments

  • kaithan1975kaithan1975 Member Posts: 851 Arc User
    It seems to be a problem for a handful of people lately, however no one has found a solution.
  • gregordynatigregordynati Member Posts: 20 Arc User
    Hello,

    For the past couple of weeks now, everytime I open the Game Launcher and click 'Engage', the screen goes black and stops responding.
    I then have to Ctrl+Alt+Del, End Task and open it again, then it works the second time.

    Is this a known issue, and are there any suggestions as to how to resolve it?

    Thanks in advance...

    I experience this too. Tried "force verify" start, but it didn't do the trick this time.
  • sthe91sthe91 Member Posts: 3,546 Arc User
    edited April 14
    Did you turn off On Demand patching and then turn on Force Verify, and let it patch?
    Where there is a Will, there is a Way.
  • gregordynatigregordynati Member Posts: 20 Arc User
    edited April 15
    sthe91 wrote: »
    Did you turn off On Demand patching and then turn on Force Verify, and let it patch?

    No, I simply added "Force Verify" and it went through the checklist then. All other settings were untouched.
    Post edited by gregordynati on
  • gaseousanomalygaseousanomaly Member Posts: 5 Arc User
    Are you using Arc? I was having the exact same issue and tried multiple things, re-installing the NVIDIA driver with Clean Installation option, verifying files, unchecking Patch OnDemand, Finally I gave up and ran the launcher directly from the installation folder, C:\Program Files (x86)\Star Trek Online_en\Star Trek Online.exe
    That at least has resulted in no more black screen with blue circle cursor so far.
  • gregordynatigregordynati Member Posts: 20 Arc User
    Yes, I am using Arc.
  • gaseousanomalygaseousanomaly Member Posts: 5 Arc User
    I would stop using Arc, make sure it isn't running and run the launcher (located in game install folder); I've run the game many times now that way and haven't had a black screen yet.
    Sad to think Arc and STO gameclient don't work nicely together.
  • gregordynatigregordynati Member Posts: 20 Arc User
    it seems that since Delta Recruit patch the problem no longer exists, at last for me.
  • kalawaykalaway Member Posts: 2 Arc User
    the problem with black screen on launch still exists i havent been able to start the the game for 3 weeks now from the launcher it still black screens every time i hit engage allready tryed all sugestions here even went as far as uninstalling sto and arc and reinstalling them as well as updateing all drivers nothing has worked sofar
  • captaincelestialcaptaincelestial Member Posts: 1,868 Arc User
    I've been having this problem since the patch before the latest one. And it happened to me about 15 minutes ago. It's still around.

    Before today, when I restart the computer to get out of the Black Screen of Death, the audio would be normal. After restarting today, the audio wasn't working. I had to shut down the computer and turn on the computer after waiting for a minute, and the audio was back to normal.

    I'm leery to start up the game today, considering I've had a couple times where restarting the computer wasn't enough to repeatedly get the Black Screen.
  • kalawaykalaway Member Posts: 2 Arc User
    edited April 19
    this may work try creating a new desktop short cut using" C:\Program Files (x86)\Star Trek Online_en\Star Trek Online.exe "it would appear that the issue is not sto or arc directly but the link between them when launching using arc it has trouble linking to sto
    bypassing arc and launching directly from sto seems to get around the issues
  • gaynomolygaynomoly Member Posts: 11 Arc User
    Same here- blackscreen. I tried all of the above including a reinstall of the game. Nothing.
    It began a over a week ago. Neverwinter would blackscreen. All I had to do was Ctrl/Alt/Delete out, and try again and it would work. Then all of a sudden it stopped doing it all together, now after a patch the game blackscreens each time.
  • jslatersjslaters Member Posts: 36 Arc User
    There is another post people been posting in that saying not to use the arc launcher as that is the problem . So check the other post it has helped me.
  • whiteknight1xwhiteknight1x Member Posts: 94 Arc User
    I been having this problem too. I finally got an error message. It stated that a game file was missing and to reinstall the game.
  • whiteknight1xwhiteknight1x Member Posts: 94 Arc User
    edited April 23
    I decided to try launching the game using the gameclient.exe since my Razer software is link to that file. I got this message.
    Unable to find required game data files. If this problem persists, reinstalling the application may fix the situation.
    This was the same error I saw earlier today using arc. Verify didn't fix this. The StarTrekOnline.exe is the 32bit launcher while the Gameclient.exe seems to be the 64bit launcher.
  • soma90soma90 Member Posts: 26 Arc User
    I'm experiencing this issue at the moment the last time I ended up uninstalling the game and redownloading it and I don't fancy having to do that again, what's really annoying is this computer is only a year old and all the drivers are up to date. I love this game but can't play it
  • gaming1ogregaming1ogre Member Posts: 30 Arc User
    I to have been having the black screen. Can't fix. Gave up fixing and now I launch the game directly, bypassing the stupid launcher.
  • gaming1ogregaming1ogre Member Posts: 30 Arc User
    I can't get the blank screen to go away. Started with delta patch. Still happening, consistently. No suggestion above works. I must start and kill STO before it works. Using the .exe has not helped me. Is there a way to make the game scan itself for errors? I can't find such an option like other games have in their launcher?
  • mandellorian#9145 mandellorian Member Posts: 17 Arc User
    I have the same issue, its the launcher..going direct to the exe works.
  • bobbydazlersbobbydazlers Member Posts: 4,531 Arc User
    Hello,

    For the past couple of weeks now, everytime I open the Game Launcher and click 'Engage', the screen goes black and stops responding.
    I then have to Ctrl+Alt+Del, End Task and open it again, then it works the second time.

    Is this a known issue, and are there any suggestions as to how to resolve it?

    Thanks in advance...

    bypass ARC or any other launcher. to do this go to "this pc" directory, open the drive the game is installed on likely "C" and then program files (x86) and look for the star trek online directory, open this directory and scroll down till you see the "Star Trek Online" icon and double click this, you might get a verify popup just click yes, the game should now launch without issue.
    if you find this works you can send a shortcut to the desktop to save time in the future, just right click and select "send to" & "Desktop (create shortcut)".
    hope this helps.

    When I think about everything we've been through together,

    maybe it's not the destination that matters, maybe it's the journey,

     and if that journey takes a little longer,

    so we can do something we all believe in,

     I can't think of any place I'd rather be or any people I'd rather be with.

Sign In or Register to comment.