test content
What is the Arc Client?
Install Arc

Anyone else with GameServer Down?

13»

Comments

  • starcruiser#3423 starcruiser Member Posts: 1,192 Arc User
    I have SWTOR working perfectly in another window. Then again they did consolidate servers there awhile back but works just fine. STO does need some major upgrading and time to feed those hamsters :)
  • doctorstegidoctorstegi Member Posts: 1,183 Arc User
    Nobody cares as long as people are dumb enough to throw money. Its a shame that Star Trek Day ended up with Star Trek Online being mostly unplayable.
    C-Store Inc. is still looking for active members on the fed side. If you don't have a fleet feel free to contact me in game @stegi.
  • fred26291#2759 fred26291 Member Posts: 1,265 Arc User
    It would be nice when they post stuff to their own forums so the rest of us can actually see where they are working on it.
    Posting it to twitter is USELESS! I WONT GO TO TWITTER FOR UPDATES!!!!!!!!!!!!!! and I wont accept any crossposts either. MUST BE GENUINE POST FROM THE DEVS ON THEIR FORUMS.
  • strathkinstrathkin Member Posts: 2,666 Bug Hunter
    edited September 2020
    Seems now the claim is, they have it resolved, ...

    And as best I can tell, it is!
    0zxlclk.png
  • methalis2003methalis2003 Member Posts: 3 Arc User
    Minutes stretch into hours and still the issue remains. Starting to recall why I stopped playing for 3 years.
  • phoenixc#0738 phoenixc Member Posts: 5,493 Arc User
    Something had Akamai all riled up earlier, their packet loss rate was insane especially in San Mateo and Cambridge. It has mostly settled down now so STO traffic is getting through.
  • neohunter200neohunter200 Member Posts: 99 Arc User
    Managed to login and play the TFO. It was laggy as hell. Got booted out of the TFO 3 times and died to lag multiple times.
  • phoenixc#0738 phoenixc Member Posts: 5,493 Arc User
    edited September 2020
    Managed to login and play the TFO. It was laggy as hell. Got booted out of the TFO 3 times and died to lag multiple times.

    If you mean the "To Hell With Honor" TFO, I think everyone dies from lag in that screwed up mess. It has to be the worst designed TFO in a long time. And that is even on good connections.
  • neohunter200neohunter200 Member Posts: 99 Arc User
    Managed to login and play the TFO. It was laggy as hell. Got booted out of the TFO 3 times and died to lag multiple times.

    If you mean the "To Hell With Honor" TFO, I think everyone dies from lag in that screwed up mess. It has to be the worst designed TFO in a long time. And that is even on good connections.
    Yup. That one. I am getting disconnected every few minutes of that TFO.

    As it stands, it is unplayable at the moment. Will give STO a break and come back later tonight after work. Hopefully the situation will improve.
  • foppotee#4552 foppotee Member Posts: 1,704 Arc User
    All was working well until Cryptic did that sudden mid-day "patch". Now getting several timing-outs trying to get into STO & once in several disconnects. Celebrate Star Trek Day? Cryptic says, "Hold my beer."
  • szimszim Member Posts: 2,503 Arc User
    Still getting disconnected every couple of minutes.
  • sniper1187sniper1187 Member Posts: 251 Arc User
    I just started trying to play, can't connect to account server.

    I tried twice with no luck, I don't care enough to try a third time. I'll play something that works until they come back up. :lol:

    Yeh, playing Dead Frontier 2 here, goof off game
    "Nuke the entire site from orbit--it's the only way to be sure"
  • aboundedorc0#8479 aboundedorc0 Member Posts: 109 Arc User
    edited September 2020
    tigeraries wrote: »
    got booted and cant get back on, keeps saying game server down at log in screen.

    This has been happening to me for many long months and it is frustrating. Reporting it seems to be a waste of time too? I get booted right out of the game during loading, whether loading into the actual game from the main screen or at any point that I manage to suddently load in and see my ship or character on ground, instantly bounced right back out of the game to the main screen with a hearty "GAMESERVER DOWN" or "disconnected from server" or "server timed out" message over and over and over, again and again and again .... followed by rinse and repeat. Half a dozen times or more EVERY SINGLE DAY! And heaven help me if I want to check in on my alt account toons (yes, I have two STO lifetime memberships).

    This problem is Cryptics. NO OTHER GAMES ON MY CONSOLE are affected and/or do this and frankly whatever their devs are able to do from home isn't cutting it. I work as a security chief in a major data center that hosts a number of high profile national or international businesses. Something like this to me is gross incompetence. Clearly whatever measure of quality assurance exists inhouse at Cryptic is not effective and I actually want to play this game; so I have checked as much on my end as possible.

    But like I said, reporting it to them accomplishes nothing.
  • fred26291#2759 fred26291 Member Posts: 1,265 Arc User
    It would be nice when they post stuff to their own forums so the rest of us can actually see where they are working on it.
    Posting it to twitter is USELESS! I WONT GO TO TWITTER FOR UPDATES!!!!!!!!!!!!!! and I wont accept any crossposts either. MUST BE GENUINE POST FROM THE DEVS ON THEIR FORUMS.

    good luck. they have abandoned the forums as any form of official newsworthy events until such time as other social media outlets have been updated, and even then, there will be times nothing makes it to the forums.

    Unfortunately, I will only go to 1 place and only one. I post here to the forums and I will not have a twitter account. So this is where the difficulty lies. If i have to now go to twitter to post problems and complaints thats fine, but I would also be under the opinion here is where that belongs so that is where the delema is located, I cant do both its one or the other. So someone has to officially tell me where I should be here or twitter?
  • cyjetcyjet Member Posts: 18 Arc User
    "new" event, "new" excuses...
  • aleaicaleaic Member Posts: 352 Arc User
    Well, an entire morning later and still am getting server booted. good lord, this is insulting.
  • jcswwjcsww Member Posts: 6,789 Arc User
    aleaic wrote: »
    Well, an entire morning later and still am getting server booted. good lord, this is insulting.

    And not a single mention of any server stability improvements in today's patch notes...
  • foppotee#4552 foppotee Member Posts: 1,704 Arc User
    jcsww wrote: »
    aleaic wrote: »
    Well, an entire morning later and still am getting server booted. good lord, this is insulting.

    And not a single mention of any server stability improvements in today's patch notes...

    Cryptic is a big fan of, "These aren't the droids you're looking for."
This discussion has been closed.