test content
What is the Arc Client?
Install Arc

BUG: Mount Suratuk's Teal Craig Cat has no insignia bonus

paedurespaedures Posts: 20Member Arc User
Nothing, nada, zip, ziltch.
Tagged:

Comments

  • bigphatie#1960 bigphatie Posts: 2Member Arc User
    Same here, have tried different suggestions from NW Customer Service -->

    " For this case, please try to remove and re-equip your insignias again, then click Apply to All Loadouts, then log out for 10-15 minutes and log in to the game. If the issue persists, please let us know so we can investigate this further."

    This did not work, so I wrote again, and they suggested this -->

    "You may also try some steps that worked for similar issues as reported by other players like changing your mount and applying to all loadouts and changing it back. Another is to force-verify your game files by doing these steps:

    1. Click the "Options" link located at the upper-right corner of the launcher.

    2. Check the option "Force verify".

    This too, was no help, but they also suggested I post on forums (for some unknown reason), obviously, I'm not the only one seeing this problem with their Crag Cat insignia bonus. Please fix this~!!! :o)
Sign In or Register to comment.