test content
What is the Arc Client?
Install Arc

little issue with quests and tracking / SW question

Im only like lvl 8 but my quest dont seem to be tracking right, ill do a part of it and it just gets stuck on that waypoint and never switches, its my first time playing so im not sure if its the area or what.

But i also had a question about the SW, im not sure what triggered it lvl 6 or summoning my companion for the first time but there is an ability in the "y" Button slot and its never been active yet in battle or else where and i have no idea what it is at the time i only had power points in dark spiritual aura and shadow walk, its a RED icon and i cant match it to anything in the powers and like it said its never been active or able to use, i tried to take a picture but it kinda sucks.... even with the iphone.

Comments

  • asleepdanasleepdan Member Posts: 9 Arc User
    edited September 2016
    http://imgur.com/a/l588B

    it didnt upload the picture i tried, im looking to find out what the skill in the "y" slot is..
  • reaper#3644 reaper Member Posts: 126 Arc User
    I don't have a sw but it is a encounter just go to your character screen look at your powers and see what is active in the y spot. It will also give you a description of what it does
  • robdingowarriorrobdingowarrior Member Posts: 14 Arc User
    more than likely its your soul puppet, I forget the name of the encounter bc I have a perma-puppet now.
  • arianocturne#1689 arianocturne Member Posts: 15 Arc User
    The quests have a bad habit of disappearing off the right hand side for me, I just usually go into the journal and retrack it.
Sign In or Register to comment.