test content
What is the Arc Client?
Install Arc

All of the animations are bugged on my Discovery character

squirrelgirl#9643 squirrelgirl Member Posts: 15 Arc User
edited October 2021 in PC Gameplay Bug Reports
Hullo, i just thought i would mention that since making a Starfleet discovery character not a single animation has gone the way it is supposed to.
I have other characters that do not suffer these problems and i know what should be happening but is not.

Most of the time it is just a stationary image of the thing with noises in the background, often with some graphical errors like things being inside each other.
The ship doesn't warp in or out properly either.

The very first mission i did after the tutorial type bit after going to Earth space dock was going to Vulcan. I hopped in the shuttle as per normal and... some noises and a stationary image of the shuttle half embedded in the ground. (instead of an animation of it landing)

It is quite jarring during the early Discovery missions that have quite a bit of animated stuff.

If i was a new player who had just finished watching Discovery or something and then came across these glitches i would be quite put off.

Comments

  • zorel#5360 zorel Member Posts: 10 Arc User
    happened to me and it's only my Disco character that's affected
  • prkl8prkl8 Member Posts: 4 Arc User
    Same for me, seems to only effect Discovery characters.
  • jameswilliejameswillie Member Posts: 133 Arc User
    Same, only with Discovery characters.
  • matth431matth431 Member Posts: 72 Arc User
    edited October 2021
    It's not just DSC characters - this is happening during cutscenes for other toons playing the Age of Discovery/J'ula's Discovery story missions. Warp effects (including mirror Disco/our Glenn spore jumps), ships cloaking/decloaking, shuttles landing/launching.... regardless of what the animation is meant to show, the ship/object is only visible in its final position without any transition.
  • warmasterxdk#9668 warmasterxdk Member Posts: 55 Arc User
    matth431 wrote: »
    It's not just DSC characters - this is happening during cutscenes for other toons playing the Age of Discovery/J'ula's Discovery story missions. Warp effects (including mirror Disco/our Glenn spore jumps), ships cloaking/decloaking, shuttles landing/launching.... regardless of what the animation is meant to show, the ship/object is only visible in its final position without any transition.

    My Mirror Crossfield (DSC toon) spore jump transwarp animation works just fine for me (PC), its the warp in/out animations that are totally broken for all my ships.
    Fingers crossed for the return of the Section 31 Heavy Rifle <3
  • matth431matth431 Member Posts: 72 Arc User
    edited October 2021
    I reported this in-game and got a pretty quick response:
    We've received other reports of this same issue. It is a known issue and the developers are currently investigating.

    Unfortunately Customer Service is unable to resolve the issue directly so we will need to wait for the fix to come from the development team.

    From our current information, a potential fix is expected to come on this date: 10/21/2021

    However, nothing about this issue is in today's patch notes...
  • zorel#5360 zorel Member Posts: 10 Arc User
    it wasn't in the notes but my warp effects are back after today's patch
  • eazzieeazzie Member Posts: 3,299 Arc User
    Animation issues with Battle At The Binary Stars also fixed :)
Sign In or Register to comment.