test content
What is the Arc Client?
Install Arc

Client verison to low

CapsunelSin - Lost CityCapsunelSin - Lost City Posts: 277 Arc User
edited October 2012 in Support Desk
I updated the game and on my launcher it says the version is 668 but when i try to log into game it says that my current client program version is to low and to exit and update but it is already updated and wont let me again what do i do?

Comments

Sign In or Register to comment.