Update of Client 11/30 2022

the update of Client keep say Error , can`t update the game the client close when push on ( OK )

is this only me it happen too or is other affected too

«1

Comments

  • taaj
    taaj Posts: 1 Arc User
    I have a "Runtime error"on the 30 November 2022 update. Hopefully it's simply because the update isn't complete. I really don't want to have to go through uninstall/reinstall again :-(
  • arinas
    arinas Posts: 2 Arc User
    Yeah same here =(
  • mortisford
    mortisford Posts: 5 Arc User
    Yes happens to me to. Runtime error message as follows. I am hoping it will resolve once the update has completed.

    C:\Program Files (x86)\PWI_en\patcher\patcher.exe

    This application has requested the Runtime to terminate it in an unusual way.
    Please contact the application's support team for more information.
  • mortisford
    mortisford Posts: 5 Arc User
    I have posted a ticket, on the basis that the sooner they know about the problem the sooner they are likely to fix it.
  • sellafewbuyalot
    sellafewbuyalot Posts: 3 Arc User
    Wait.. they actually try to fix things in PWI?
  • plushie666
    plushie666 Posts: 181 Arc User
    Same here, best to submit a ticket to support so they work on this faster.
  • buffingme
    buffingme Posts: 9 Arc User
    press control, alt, delete go to task manager..end processes that are related to arc then restart it should update after that at least it did for me
  • fededomino
    fededomino Posts: 228 Arc User
    press control, alt, delete go to task manager..end processes that are related to arc then restart it should update after that at least it did for me

    that process dont work for me , we can only hope PWI FIX this very fast
  • den28nl
    den28nl Posts: 41 Arc User
    The patcher works fine on linux, but servers are down anyways.
  • cafp2010
    cafp2010 Posts: 4 Arc User
    My patcher shuts down every time I try to update, so I can't do anything either. Ticket submitted.
  • puangi#2208
    puangi#2208 Posts: 78 Arc User
    Uninstall the game through arc and reinstall it again (Unfortunately) and it should work. Submitting a ticket won't help as the same issue occurred during the Fountain of fate update.
  • den28nl
    den28nl Posts: 41 Arc User
    cafp2010 wrote: »
    My patcher shuts down every time I try to update, so I can't do anything either. Ticket submitted.

    Windows 10 or 11?
  • cafp2010
    cafp2010 Posts: 4 Arc User

    den28nl wrote: »
    cafp2010 wrote: »
    My patcher shuts down every time I try to update, so I can't do anything either. Ticket submitted.

    Windows 10 or 11?

    Windows 10
  • den28nl
    den28nl Posts: 41 Arc User
    the game is not working for me on windows 10 & 11, but on linux it runs
  • zafra2010#4866
    zafra2010#4866 Posts: 1 Arc User
    den28nl wrote: »
    The patcher works fine on linux, but servers are down anyways.

    are the servers still down?
  • den28nl
    den28nl Posts: 41 Arc User
    I'm more and more suprised that this company has the guts to ask thousands of dollars for ingame items, but refuses to fix the most basic server errors, Arc issues and still hasn't found a solution for the DST resets for over 12 years.
  • plushie666
    plushie666 Posts: 181 Arc User
    Uninstall the game through arc and reinstall it again (Unfortunately) and it should work. Submitting a ticket won't help as the same issue occurred during the Fountain of fate update.

    Did reinstall the game, took me 3hours but it working now.
  • kathiawellina
    kathiawellina Posts: 33 Arc User
    Well well. Now it finally got to me, after me not being affected by the Fountain of Fate update. What is in this patch, that they managed to break it? Usually it happens, when there is an event incoming. But someone said, there is nothing new. There is a wider range of people affected by this error, than with the Fountain of Fate update. Was there some visuals updated? I indeed lack the 2022 update from c++, so maybe installing that might fix it. If not, I'd suggest to file a ticket. If there is more than 1k Tickets, it has to be taken serious enough, to not suggest in ticket to ask the missing community manager on this forum, who has not been emploeyed yet.
    Venomancer "Nalaira" from Dawnglory Server 18th August 2015
    Venomancer "Nehilenia" from Twilight Temple Server (Ex-Sanctuary) 12~14th Nov' 2008 - December 2012
    bannergzjd0.png
  • docphilanthropy
    docphilanthropy Posts: 5 Arc User
    this is outrageous taking me hours to delete and reinstall and then i dont know for sure it will work. what is pwi going to give ppl for this as compensation?
  • widowdee
    widowdee Posts: 94 Arc User
    this is outrageous taking me hours to delete and reinstall and then i dont know for sure it will work. what is pwi going to give ppl for this as compensation?

    Probably nothing.
  • thesandman#6129
    thesandman#6129 Posts: 2 Arc User
    Hope this wont take two weeks like the aslt messup
  • thesandman#6129
    thesandman#6129 Posts: 2 Arc User
    sure not going renistall
  • kathiawellina
    kathiawellina Posts: 33 Arc User
    this is outrageous taking me hours to delete and reinstall and then i dont know for sure it will work. what is pwi going to give ppl for this as compensation?

    most likely x2 drops. Which should be going on around christmas anyway. So I'd rather like an event that gives bell of garment, royal glow fan and dragon tamer lasso, that I can save up till the next update hits.

    But most likely nothing, just as with the DST maintenance compensation, which has not happened yet.
    Tbh I'd be just happy, if we are getting any sort of solution to this problem. As there is nothing we could do from our side, cause it is their side. Or they should warn, that you need to update your c++ with next patch, if there is complicated to display fashion and mounts inside that monthly boutique update. It's unlikely that there is the dragons rise in this patch, but will see tomorrow, after change from november to december, they can launch events afterwards. Usually boutique updates should not break the client, like this did. There must be some event code, that cause this trouble. Remember what happened when we had this small event going on in end of october.
    Venomancer "Nalaira" from Dawnglory Server 18th August 2015
    Venomancer "Nehilenia" from Twilight Temple Server (Ex-Sanctuary) 12~14th Nov' 2008 - December 2012
    bannergzjd0.png
  • plushie666
    plushie666 Posts: 181 Arc User
    edited November 2022
    This error is usually related to some missing/outdated Visual C++ Redistributables.

    The developers recommend the following steps:
    1. Uninstall your existing Microsoft Visual C++ 2015-2022 Redistributable installations. You can do this under the Add or Remove Programs section in Windows (press Start, type ADD and select "Add or Remove Programs").
    2. Navigate to this page: https://docs.microsoft.com/en-US/cpp/windows/latest-supported-vc-redist?view=msvc-170
    3. Download and install both the x86 and x64 versions under Visual Studio 2015, 2017, 2019, and 2022 from this page.
    4. Reboot your PC.
    5. Run PWI again and see if the patching process works correctly.

    If the issue persists:
    1. Open a command prompt as an administrator (press Start, type CMD and underneath the "Command Prompt" app select "Run as administrator").
    2. Type the command: sfc /scannow
    3. Let the process complete.
    4. Run PWI again and see if the patching process works correctly.

    All users that had encountered the runtime error eventually were able to be self-resolved.
    If the steps above did not work, there are a few more solutions to try below.

    Alternatively, if you have access to another device that can have PWI installed and working, there is a less common solution that could work as well.
    If you remove and replace the entire game folder of PWI_en from the working PC to the errored PC, the lengthy patch process would not be needed and you should then be able to skip the error altogether.

    Other users have also been able to update after switching to 32-bit mode. If you check the gear icon next to the Play button in the Arc client, go under Advanced Settings and change it to 32-bit. After the launcher is running, if you are also able to click on the Graphics button, uncheck the 64-bit box so that it's also running in 32-bit mode.

    Lastly, if you're also willing to try a new install of both the Arc client and game, a fresh start was able to help some users get started on downloading without errors as well.

    However, due to the game size, this can cause some problems for users with limited network availability.

    -uninstall the PWI game from the arc client
    (option should be listed when clicking the gear icon next to the PWI Play button)
    (if uninstall for PWI is not listed, continue with uninstalling Arc)
    -uninstall Arc client

    -delete the PWI_en folder from where the install directory of the game was located
    -restart the computer

    -download and install Arc
    -download and install PWI from the Arc client

    Reinstalling was what worked for me, because my windows was up to date, no problem there.
  • buurman#2138
    buurman#2138 Posts: 12 Arc User
    Reinstalling was what worked for me, because my windows was up to date, no problem there.
    Same for me: reinstalling while doing more important stuff :D
  • puskarunkkari
    puskarunkkari Posts: 3 Arc User
    This game is just destined to be ran by a bunch of complete donuts
  • den28nl
    den28nl Posts: 41 Arc User
    the DST compensation is appropriated, thank you.
    code nsCklp7J
  • den28nl
    den28nl Posts: 41 Arc User
    den28nl wrote: »
    the DST compensation is appreciated, thank you.
    code nsCklp7J

  • technoplume3
    technoplume3 Posts: 111 Arc User
    Well nothing listed here works, so I guess it's gonna be good bye.
  • princessfyre
    princessfyre Posts: 1 Arc User
    mortisford wrote: »
    I have posted a ticket, on the basis that the sooner they know about the problem the sooner they are likely to fix it.

    I have also submitted a ticket. so over this!