CPU getting pegged in social areas of game

My system is beefy, and the CPU even though it's the weakest link should be able to handle 3 instances of the game running at once. Instead just trying to run as normal this happens.
unknown.png

And I get 1-2 seconds of responsiveness followed by 10-20 seconds of frozen game (but the mouse pointer moves), and repeat. What could be going on and how can I fix it? I tried turning shadows down, turning off AA, and going from windowed fullscreen to true fullscreen but it made no difference. The game wasn't always like this, though it's done it occasionally, but as of the past 2 weeks or so it's been unbearably bad, especially in ESD and DS9.

Comments

  • keepcalmchiveon
    keepcalmchiveon Member Posts: 4,012 Arc User
    while maybe not the sole issue, or at all, i found that turning off lighting 2.0 for the whole game has improved system fans, heat, etc...
    my fans now will run, but at a much lower level as the laptop isnt as hot anymore with 2.0 off.

    again, not saying this is the issue, but maybe try it and see if it helps or fixes it.
    meh

  • sianmink#4049
    sianmink#4049 Member Posts: 6 Arc User
    it's obviously bad in social areas, but in ship play it's also gotten very bad.
  • sianmink#4049
    sianmink#4049 Member Posts: 6 Arc User
    Turning off shadows has completely stopped the problem.
    Now to figure out, is there a way to re-enable shadows without destroying my performance? This problem has only been a recent issue.
  • sianmink#4049
    sianmink#4049 Member Posts: 6 Arc User
    Turning off shadows has completely stopped the problem.
    Now to figure out, is there a way to re-enable shadows without destroying my performance? This problem has only been a recent issue.

    it didn't completely stop the problem, just lessened it.
  • jcsww
    jcsww Member Posts: 6,555 Arc User
    I wouldn't call anything with a 4770k beefy about 8 years after it's released. :P I do have a 4770k system though that I use for a few things, including a backup. It will easily run 5 instances of STO with an XFX Radeon 390 GPU and 16GB of RAM. Up until mid October when I built a 12-core Ryzen 5900X system with 64GB of RAM and a Radeon 6900XT. I would literally private instance the game to run multiple accounts through TFO's and everything ran smooth. Perhaps you need to lower your overclock a little for stability. I still have my 4770k overclocked, but it runs at a modest 4GHz but it has been stable at that since I have built the system way back in 2013 or 14... So long ago!
  • sianmink#4049
    sianmink#4049 Member Posts: 6 Arc User
    I did pull back on my overclock thinking that might have been the issue but it did nothing.
    I know the 4770k should be able to annihilate STO, especially with 16gb and a freaking RTX3070. It ran fine two years ago with the same hardware but a 1070.
  • sianmink#4049
    sianmink#4049 Member Posts: 6 Arc User
    jcsww wrote: »
    Perhaps you need to lower your overclock a little for stability. I still have my 4770k overclocked, but it runs at a modest 4GHz but it has been stable at that since I have built the system way back in 2013 or 14... So long ago!

    Looks like you were onto something. I pulled my overclock from 4400Hz to 4000Hz and everything smoothed out.
  • jcsww
    jcsww Member Posts: 6,555 Arc User
    jcsww wrote: »
    Perhaps you need to lower your overclock a little for stability. I still have my 4770k overclocked, but it runs at a modest 4GHz but it has been stable at that since I have built the system way back in 2013 or 14... So long ago!

    Looks like you were onto something. I pulled my overclock from 4400Hz to 4000Hz and everything smoothed out.

    Good to hear. Happy gaming!
  • whiteknight1x
    whiteknight1x Member Posts: 122 Arc User
    edited January 15
    This might help. I have a Gigabyte motherboard and was getting random crashes. I clean installed the OS many times but it didn't help. I started looking at every line in my BIOS and discovery this setting Above 4G Decoding it was disable by default. This setting allow 64bit OS to exceed the 4G limit. For some reason this was disable This may have happen during a BIOS update.