test content
What is the Arc Client?
Install Arc

Crash on Launch

Hello,

Since the start of the year I've experienced crashes when trying to launch STO. I'll hit engage, make it to the cryptic screen, and then be met by the crash report window.

As of right now, I have: uninstalled/reinstalled multiple times, done safe launch, and reverified files,

There have been small windows where I have been able to play the game, but I don't know what went right in those instances to allow me to play.

Has anyone else had this problem?

Thanks for popping by and reading this post (:
Tagged:

Comments

  • strathkinstrathkin Member Posts: 2,296 Bug Hunter
    Try updating Video Drivers... Most often the issues can be caused there.
    R2XG2I3.png
  • xenosisukxenosisuk Member Posts: 41 Arc User
    I was playing STO earlier, had to exit game due to Householde chores :smile: came back after I did them constantly CTD now with the Cryptic Error thingy giving me a code, looks like random codes to me as never the same one, I actually Uninstalled/reinstalled, then uninstalled/reinstalled onto an SSD instead of the HHD I had it on before incase that drive was failing but nope, CTD everytime when the Cryptic Logo shows up, reverifying the files again now, will come back to let you know how it goes.
  • thatguy2965thatguy2965 Member Posts: 2 Arc User
    strathkin wrote: »
    Try updating Video Drivers... Most often the issues can be caused there.

    Sorry for the delay, class's have been hell. At the time of your message, I was update on my graphics drivers. There was a point in late March where it was working, but then today (with up to date drivers) the problem continues. I'm guessing it's something with the game at this point.
Sign In or Register to comment.