test content
What is the Arc Client?
Install Arc

was there an update?

Was there a graphical update or something? Or a system requirement update? Because 4 months ago, this game ran pretty smoothly on my PC, now even on medium graphics is slow and laggy as hell.
gQytlm7.jpg

Comments

  • thegrandnagus1thegrandnagus1 Member Posts: 5,126 Arc User
    I don't think there was any significant graphics update in the past 4 months, no.

    The-Grand-Nagus
    Join Date: Sep 2008

    og9Zoh0.jpg
  • spiritbornspiritborn Member Posts: 3,762 Arc User
    edited February 2021
    No graphics updates recently (as in the last 6 months or so) as far as I know, You might want to check that you're not running anything on the background (including making a virus/malware check just to be sure). I've not seen any significant performance change during that 4 months window and I've played STO fairly consistently.

    Though depending on where you live it could also be a network issue (having a bad connection will slow everything in the game not just cause SNRs and rubberbanding) and it could also be a driver issue. Either way (and I know this is not something you want to hear) the issue is probably at your end.

    EDIT:If it was a Cryptic's end it would be universal not just for some people and my rig ain't that great either, though some effects do lag even my PC though they tend to happen fairly rarely.
  • evilmark444evilmark444 Member Posts: 6,893 Arc User
    Was there a graphical update or something? Or a system requirement update? Because 4 months ago, this game ran pretty smoothly on my PC, now even on medium graphics is slow and laggy as hell.

    Most likely there's something going on with your computer, check task manager and make sure there's nothing in the background using up a bunch of system resources, try closing tabs in chrome if you have a bunch open, etc. Could also be hardware related, like a failing graphics card or something. A few years ago my power supply started going bad but the only symptom was that modern games crashed shortly after loading.
    Lifetime Subscriber since Beta
    eaY7Xxu.png
  • edrickvellorinedrickvellorin Member Posts: 345 Arc User
    Some things to check out:
    1. See if your game is set to run in Windowed mode, if so, try switching to Fullscreen mode. Depending on your hardware/software setup, that could make a major difference.
    2. One thing that might influence performance a bit would be some of the updated ship models.
    3. If you're specifically having trouble in Storming the Spire, and didn't really do Dyson Sphere stuff before, that could be an issue. The Dyson Sphere areas were harder on my old comp then most other areas of the game. Turning Lighting 2.0 off for Dyson Sphere stuff (and on occasion at other newer content areas) helped.
    4. Early Klingon faction missions got a major revamp and First City got some visual upgrades, which might affect performance. Likewise, newer episode missions may be harder on your system then some older content.
    5. Some visual effects from newer content may cause temporary framerate issues. (The console from the Risa WCS or some of the Risa Kit Modules come to mind after using them on my old computer.)
    6. All sorts of non-STO stuff could potentially be causing issues. Like Windows Update.

    For most of last year I was running the game on a 7 year old laptop, so those are some of the things I noticed. A separate issue I've also noticed is the Zen store. When the Zen store is open, your FPS will drop quite a bit, even on a good computer. Not quite sure why, though I've got a theory.
  • livinlifejb90#4082 livinlifejb90 Member Posts: 218 Arc User
    thank you all for the responses!
    gQytlm7.jpg
Sign In or Register to comment.