Storm Clouds Gather Ore Processing area problem

goldenavariel Member Posts: 108 Arc User
Our group was unable to finish the ground combat portion of the "Storm Clouds Gather" mission because the second walkway's rotation console wouldn't become active. We could extend/extract the walkways all day long but without rotation we couldn't get to the final area at the top of the room.

Of course the problem with "Continue" doing a restart on the whole mission is still a thing too so we gave up after the first problem since it was getting close to time to quit anyway. Could be it'll work fine on the second pass but obviously something is wrong.

Is it my imagination or has this mission been terribly buggy since it launched and hasn't really gotten any better?


  • ayexeyen
    ayexeyen Member Posts: 218 Arc User
    It is TRIBBLE buggy, moreover the bridge officers do not follow in the walkway. I usually found myself fighting the Hurq alone on the last stage.
  • enigmachad#4351
    enigmachad#4351 Member Posts: 25 Arc User
    edited November 2019
    yes, seeing this on multiple characters including Jem Hedar. can't power relays says "cannot us this item." tried multiple times.
  • kaithan1975
    kaithan1975 Member Posts: 947 Arc User
    Mission works fine, just did it on a Jem'Hadar, twice.
  • rndfluctuation#1470
    rndfluctuation#1470 Member Posts: 813 Arc User
    edited November 2019
    Some things which may help you (I did the mission on some characters):

    Don't approach consoles from the opposite side...

    Alert may interrupt likely though I don't remember,

    You may gather your Boffs now. (Request Reinforcement from bellow the party avatars?) It MAY possibly help if they are still stuck in other parts.

    Pay attention to what you're doing/having to do, the order of things or your goal. Things need to be withdrawn/retracted from other place before available and then you may need to rotate up or down so that will help YOU in the level / area you are. (regarding the approaching "road" and the "should-be-matching" "opening") -sorry can't be accurate here.

    *I don't know what happened if you have other players there, there was an issue but it was allegedly solved - no idea about the real current status in that regard. I'd recommend to play this mission solo - with your Boffs. (see note above)
    Post edited by rndfluctuation#1470 on