test content
What is the Arc Client?
Install Arc

DirectX 11 Error Code (E_OUTOFMEMORY)

velquavelqua Member Posts: 1,215 Arc User
Not sure if anyone else is or has had STO crash due to the DirectX 11 Error Code (E_OUTOFMEMORY) since Season 13's patch. I have had this issue since I switched over from DirectX 9 to DirectX 11. Starting with Season 13's patch, this issue has become worse. I can only do 1 or 2 PvE queues before the game starts to crash. I do feel like there is a memory leak somewhere. I remember there being an issue with DirectX 9, but somewhere along the line it had been addressed. I am hoping this gets addressed some time soon.
18662390068_f716cd60e3.jpg

Comments

  • jaguarskxjaguarskx Member Posts: 5,945 Arc User
    How much system RAM and video RAM do you have?
  • velquavelqua Member Posts: 1,215 Arc User
    jaguarskx wrote: »
    How much system RAM and video RAM do you have?

    Video RAM: 1,696 MB
    System RAM: 4,096 MB
    18662390068_f716cd60e3.jpg
  • jaguarskxjaguarskx Member Posts: 5,945 Arc User
    edited April 2017
    Try lowering some graphic settings. For example, if you have character, terrain and world detail set to max bring it down to high. Maybe lower texture anisotropic filtering down a bit as well.

    4GB of RAM is considered low these days, but it should be fine for playing STO. I have 16GB of RAM in my systems, but that last time I checked, when I was only running STO and nothing else in the background the desktops / laptops were using something like 3.9GB of RAM.


    Have you tried uninstalling your graphic drivers, then installing the latest version?
  • grayfoxjamesgrayfoxjames Member Posts: 1,516 Arc User
    I have the same issue. Never got that message before Season 13 now I just can't play get booted every 3 minutes
    Fleet Admiral Thomas Winston James a.k.a. The Grayfox
    Fleet Leader of:
    Liberty Task Force/Liberty Honor Guard
    Pride of the Federation/Pride of the Empire
    Liberty Guardians
    U.S.S. Liberty, NX-42813-L, T-6 Legendary Odyssey Class

    Game Handle: [email protected]
    Website: https://www.libertytaskforce.com
    Armada (STOFA Member Fleet): https://www.libertytaskforce.com/stofa
    Discord: https://discord.gg/bGp9N7z
    Twitter: [email protected]
    Email: [email protected]
  • jaguarskxjaguarskx Member Posts: 5,945 Arc User
    It's a bit tedious, but can both of you do a force verify or worse, reinstall the game?
  • bloodyrizbloodyriz Member Posts: 1,756 Arc User
    Today my game crashed while I was doing "The Warehouse" on New Rom, and now every time I try to launch the game I get this error. I have tried a force verify, and it is still doing this. I will have to try an fresh install I guess. Sadly that means no playing for a while.​​
    signature.png
    We come in peace, SHOOT TO KILL!
  • bloodyrizbloodyriz Member Posts: 1,756 Arc User
    **UPDATE**

    So I did not uninstall/reinstall yet. I did kick my launcher into safe mode and got in first try. If I hit future snags on this error I will update again.​​
    signature.png
    We come in peace, SHOOT TO KILL!
  • grayfoxjamesgrayfoxjames Member Posts: 1,516 Arc User
    Please do...you can't play the game in safe mode though the whole time no??
    Fleet Admiral Thomas Winston James a.k.a. The Grayfox
    Fleet Leader of:
    Liberty Task Force/Liberty Honor Guard
    Pride of the Federation/Pride of the Empire
    Liberty Guardians
    U.S.S. Liberty, NX-42813-L, T-6 Legendary Odyssey Class

    Game Handle: [email protected]
    Website: https://www.libertytaskforce.com
    Armada (STOFA Member Fleet): https://www.libertytaskforce.com/stofa
    Discord: https://discord.gg/bGp9N7z
    Twitter: [email protected]
    Email: [email protected]
  • bloodyrizbloodyriz Member Posts: 1,756 Arc User
    Actually, I did play the entire session in safe mode. I just had to turn occlusion back on so the transparencies worked. Then next time I fired the game up no issues at all.​​
    signature.png
    We come in peace, SHOOT TO KILL!
  • ometaklahnometaklahn Member Posts: 17 Arc User
    I get the same error too now. Locate your localdata file and delete the GamePrefs.pref file. This will reset your graphics settings, but will help the game loadup better. The only problem is that the system will restore GamePrefs.pref file after a while. So you will have to keep deleting it when you notice a problem has reoccurred. If that doesn't work then something else is going on.
  • gaevsmangaevsman Member Posts: 3,183 Arc User
    edited May 2017
    ometaklahn wrote: »
    I get the same error too now. Locate your localdata file and delete the GamePrefs.pref file. This will reset your graphics settings, but will help the game loadup better. The only problem is that the system will restore GamePrefs.pref file after a while. So you will have to keep deleting it when you notice a problem has reoccurred. If that doesn't work then something else is going on.

    ^^This!, sometimes, the gameprefs file gets corrupted, and you have to delete it.. not a biggie, as is very rare that this happens.. but its the best solution.
    The forces of darkness are upon us!
Sign In or Register to comment.