test content
What is the Arc Client?
Install Arc

Launcher stuck on "Loading, please wait" forever. After I did a clean Windows 10 reinstall

Done this dozens of times over the years, this time, it's not getting past launcher screen. I have the original Star Trek Online Collector's edition, box set. Played the game, worked fine, until this clean reinstall of both Windows 10 and this game. Has something changed with Windows latest version or with launcher?
Put in support ticket, but I'm hoping I can get a faster answer on this forum.
Looking to really get back in the Star Trek world, watched Original Series on TV in 1960s as a grade schooler. Thanks in advance for any suggestions or clues.


  • dochollideydochollidey Member Posts: 3 Arc User
    FYI - Everything else on computer is working perfectly. I have 150mbps, 12 ping Comcast connection. I've looked elsewhere on this forum and apparently, this has happened to others. It's never happened to me, though, lol.

    Used to run a computer store, this appears to be an Internet connection issue, but if STO is the only thing that doesn't work, I'm not going to change things just to accommodate STO - darn it!
  • ekypyrosekypyros Member Posts: 179 Arc User
    edited July 2018
    Have you test to start the launcher as Administrator ? Right Klick and Run As Admin
  • dochollideydochollidey Member Posts: 3 Arc User
    Yeah, tried running as Administrator, too, no dice.
  • majorhalcyonmajorhalcyon Member Posts: 199 Arc User
    Check your firewall; it should have thrown a prompt when you first tried loading it/the game to allow at least 'GameClient' through, but it's sounding like maybe it's being blocked...
Sign In or Register to comment.