Popping Sound in Ground Maps

reximuz
reximuz Member Posts: 1,164 Arc User
edited April 2014 in Graphical and Sound Issues
Since Season 9 I have been getting a popping sound on at least some ground maps, I haven't been getting it on any space maps so far. Specifically I am getting it on ESD and New Romulus Command. Additionally, the popping will continue even when STO doesn't have focus, even though I don't have any other sound from STO when it doesn't have focus.

Not sure if its just a bug, or if there might be something I can tweak in my settings.
Post edited by Unknown User on

Comments

  • fazemladaiya
    fazemladaiya Member Posts: 166 Arc User
    edited April 2014
    This has actually been an issue for quite a while. I reported it last year in this thread:

    http://sto-forum.perfectworld.com/showthread.php?t=695261

    EDIT: I found a workaround for now that works. See my reply below.
  • fazemladaiya
    fazemladaiya Member Posts: 166 Arc User
    edited April 2014
    1. Download VB-Cable Driver from here: http://vbaudio.jcedeveloppement.com/Download_CABLE/VBCABLEDriver_Pack42b.zip
    2. Install the driver – NOTE: You will NOT have any shortcuts in your start menu or desktop. This is just a driver that simulates a cable.
    3. Right click on your speaker icon in your task bar then select “Playback Devices”.
    4. On the PLAYBACK tab, select “CABLE Input” as your default.
    5. On the RECORDING tab, select “CABLE Output” as your default. NOTE: Do not panic. This will NOT affect microphone usage, and it is normal for the microphone to still react on the equalizer in this dialogue window – that’s how it is supposed to be. But if you do not do this step, you will have no sound at all.
    6. Highlight “CABLE Output” and select “Properties”
    7. On the LISTEN tab, click “Listen to this device”, then select your speakers/headphones that you are using from the pull-down menu. NOTE: Yes, we are still working with the recording tab, but you want your output device selected. For me, this was “Speakers (Logitech G35 Headset)”
    8. Click APPLY then OK. Yes, you should do both, I don’t care how lazy you are.
    9. Again, click APPLY (if it’s not greyed out) then OK
    10. Enjoy a MOSTLY pop free STO

    Here is the science: Windows has issues with being a nit-pick for communication with devices regardless of your settings. Since a virtual cable is stereo only and does not process 7.1, Windows will tell your game not to push 5.1/7.1 sound through to the device. It will recognize the device as a stereo only device. 7.1 surround headsets are not even real 7.1 – they only simulate the sound of 7.1 to trick your ears. As a result, however, it tells Windows that it is a 7.1 device, thus the game will try to push surround sound to the headset regardless of headset settings.

    The result of the above fix for me: ALL popping pretty much disappeared. The only anomaly is that when I start to beam out of a map, I get a single pop, but that’s it! I tested this on all of the maps I had huge issues with – especially Assimilation, as well as the new Season 9 featured episode. Before this fix I would consistently get pops every 2 – 3 seconds – it felt like I was playing STO while sitting inside a popcorn machine at the movie theater. After this fix – I only get a single pop when I beam out from a ground map.

    To me this is not a fix, but rather a workaround until either Microsoft or Cryptic or Asus – whoever the hell can find a permanent fix for this issue for those who have the issue, can fix it. But regardless I consider a single pop during beam out to be a far better workaround than every few seconds.

    A note on Virtual Cables – DO use the one I linked. Do NOT attempt this with “Virtual Audio Cable” by Eugene Muzychenko. That software is TRIBBLE and it is pay-ware anyway. VB-Audio software is completely free as they run only on donations – a true open source developer that respects the community.

    I hope this information helps others. Happy gaming.