test content
What is the Arc Client?
Install Arc

Professions not working

kumalucakumaluca Member Posts: 51 Arc User
edited August 2014 in Bug Reports (PC)
My professions are complete but I can't collect them they just stay complete.It's been about 3 days.Any ideas or anyone else having this problem?Thanks in advance.I have a fast connection and everything else is running smooth.I have tried consistently not just a few times.

Post edited by kumaluca on


  • chaoscourtesanchaoscourtesan Member, Neverwinter Beta Users Posts: 0 Arc User
    edited August 2014
    Only time this has ever happened to me is when my inventory was full. You can't collect if there is nowhere to put the reward. If that isn't the issue then you have a very strange one and you should certainly open a ticket.
    Rhyon Cawdorian GWF | Opa Loka TR | Cormac Argentus III DC | Annika Thornblade GF | Aerys Skydark HR | Bartin Findlor TR | Aellia Baalthrall CW | Lucan Hawkmoon CW | Opa Brahk GWF | Korzbyrk DC | Den Kruk GWF | Jherek Skarsin CW |
    Roland Mac Sheonin GF | Tarron Direheart SW |
  • kumalucakumaluca Member Posts: 51 Arc User
    edited August 2014
    that's what's driving me nuts,I have plenty of open slots.
  • charononuscharononus Member Posts: 5,715 Arc User
    edited August 2014
    Have you tried the gateway?
  • iambecks1iambecks1 Member Posts: 4,044 Arc User
    edited August 2014
    Are the spaces in your top bag? if not try to make a space and see if you can collect the result then? if that doesn't work you need support.
  • valkyriazavalkyriaza Member Posts: 4 Arc User
    edited August 2014
    I'm sorry to hijack this thread a little, but as per this forum rules I cannot post a new thread until an unspecified probationary period has passed. One of the reasons I did sign up is to submit a bug report and see if anyone else has a similar experience.

    I've started missing profession resource items after playing Sword Coast adventures. My 60th level character has lost 2 adventurers (Leadership), all Zen on the account (almost a 1000 points) and some astral diamonds. I hadn't received any notifications about other computers logging in on my account.

    I did change the password after noticing the missing resources, but yesterday the same 60th level character loses yet another three high level Leadership resources, but thankfully no Zen or Astral diamonds. one of my other characters lost another two high-level leadership resources as well, all after the password change and I didn't play Sword Coast adventures at all. Other characters hadn't been affected from what I could see.

    I have logged this as a bug report on Arc Games, but I'm curious if anyone has encountered this as well. This is somewhat worrying, since there seems to be no evidence of hacking the account and my in-game gold as well as other resources in professions are still in tact.

    P.S. Both the computers on which I played Sword Coast adventures are firewall protected and used exclusively by me.
Sign In or Register to comment.