New mythic mount missing equip power

arieswytch#9832
arieswytch#9832 Member Posts: 98 Arc User
After equipping the new mythic mount, I went to equip the mount power, but it is not in the list. For all my other toons that claimed and equipped the mount, the power is there, but the first toon I equipped it on from out of the lockbox does not have it available.

Comments

  • cryptic39#8917
    cryptic39#8917 Member, Cryptic Developer Posts: 80 Cryptic Developer
    Thank you for your report. There is an issue with the way this power is rewarded to you that is bugged, and will be addressed in in a near future patch.
  • giannix1
    giannix1 Member, NW M9 Playtest Posts: 5 Arc User
    Almost similar problem but with the legendary mount.
    I bought the new legendary account mount in the auction but it doesn't equip in other characters
  • coralt
    coralt Member, NW M9 Playtest Posts: 1 Arc User
    I bought a legendary mount hag's cooking cauldron account, I equipped a character in my account but with the other characters in my account it does not equip it, it tells me "you already have all the elements of this pack"
  • alleykate
    alleykate Member Posts: 42 Arc User
    I have the problem (listed above) where after equipping the new mythic cauldron mount after the first character, on alts they are not showing on the list, the mount bolster remains unchanged and can't see the mount power. I go to get it again from the reclaims vendor and it tells me I already have it despite it not appearing, no increase to the bolster or powers being available. I have tried logging out and logging back it, but it still appears as not there.
    Guild - Fair Dinkum 2.0
    Part of Team Tredecim of the Cloaks Alliance website
    https://cloakalliance.wordpress.com/
  • murphystout
    murphystout Member Posts: 67 Arc User
    Just like last launch. I get lucky on a lock box and get a mythic account wide mount that is only claimable on one character successfully. It took you 5 weeks to resolve this issue last time. It took 2 of those weeks just for you to agree there was a problem. The time is running.
  • justkickinit
    justkickinit Member Posts: 53 Arc User

    I got the mystic version of this mount from a lockbox. It is on the list of mounts for the character who claimed it and she is able to equip it. However, for my other characters, who claimed it from the "promo" menu and equipped it, it is not showing up on the list of mounts available.

    Same problem. I can see it my first Character stable list but not in subsequent characters.

  • plasticbat
    plasticbat Member, NW M9 Playtest Posts: 10,441 Arc User
    edited February 2021

    Just like last launch. I get lucky on a lock box and get a mythic account wide mount that is only claimable on one character successfully. It took you 5 weeks to resolve this issue last time. It took 2 of those weeks just for you to agree there was a problem. The time is running.

    This time they acknowledged it within hours if not hour.

    https://www.arcgames.com/en/forums/neverwinter/#/discussion/1260116/pc-sharandar-launch-week-issues/p1
    The game can read your mind. If you want it, you won't get it. If you don't expect to get it, you will.
  • miyagi#6886
    miyagi#6886 Member Posts: 21 Arc User
    I'm glad I'm not alone on this one. Was about to throw tantrums. LoL
  • doompriest70
    doompriest70 Member Posts: 8 Arc User
    Only receiving hags cauldron on one of my toons, the others can take it out of the claims tab and click on it and receive the mount power. But the mount is not there to use? Is this intended? It said account.
  • kough#3586
    kough#3586 Member Posts: 6 Arc User
    Having the same issue. Hag's cauldron was first claimed on my fighter. The fighter has the stabled mount, mount appearance and mount power but no awareness power (omnipotent). On the other toons that collected the mount they only got the awareness power and no mount power, appearance or, stabled mount.
  • mentinmindmaker
    mentinmindmaker Member Posts: 1,367 Arc User
    On two of my characters(the best developed ones) I can claim the Legendary Cauldron, but I cannot put it into stable.

    When I click it to put it into stable I get the error message 'You already have all items in this package'.

    I have checked if those characters somehow got the Legendary Cauldron already, but it is not available in the choice of mounts to ride.

    The other characters on my account were able to claim and stable it as usual.
  • baalhashmal
    baalhashmal Member, NW M9 Playtest Posts: 65 Arc User
    Cannot reclaim account bound Hag's Cauldron [Legendary] on other characters.

    See images below; I do not have the mount in my stable.

    picture-1
    picture-2

    Cleric: Marquis Elmdore - Current Main <3
    Wizard: Iamblichus
    Fighter: Anna the Titan
    Barbarian: Anann Valkyrja
    Ranger: Minerva Cory'phaia
    Warlock: Suri Coralyne Reid


    Guild: She Looked Level 18.
    Alliance: Imperium
  • arieswytch#9832
    arieswytch#9832 Member Posts: 98 Arc User
    edited February 2021

    After equipping the new mythic mount, I went to equip the mount power, but it is not in the list. For all my other toons that claimed and equipped the mount, the power is there, but the first toon I equipped it on from out of the lockbox does not have it available.

    I wanted to elaborate on this. I'm actually facing several bugs with the new mount. The toon that got the mythic Hag's Cauldron from the lockbox was able to equip the mount and can use the mount to ride. The equip power is missing, but she does have access to the combat power. She can also swap it into the stable for the insignia bonus.

    2 of my toons cannot equip the mount at all. They both have a version of a crag cat mount that has the Omnipotent equip power at a lower level. I get the error message "You already have all items in this package."

    All of my other toons were able to claim and equip the mount, however they cannot choose the mount to ride, it's not showing in their list. They do have access to the equip power, but DO NOT have access to the combat power, nor can they swap it into their stable for the insignia bonus.

    (ETA more detail.)
    Post edited by arieswytch#9832 on
  • mintmark
    mintmark Member, NW M9 Playtest Posts: 123 Arc User

    After equipping the new mythic mount, I went to equip the mount power, but it is not in the list. For all my other toons that claimed and equipped the mount, the power is there, but the first toon I equipped it on from out of the lockbox does not have it available.

    I'm having the OP's problem, but with the legendary version of the mount. I have the mount, but I can't select the equip power "omnipotence".
  • mintmark
    mintmark Member, NW M9 Playtest Posts: 123 Arc User
    In case it helps anyone, I've discovered that if you get another lower level mount with same equip power, omnipotence, then it unlocks the power from your cauldron at legendary or mythic level. For me it was unlocked by a green owlbear (at blue quality level) from Juma.
  • violencebf22
    violencebf22 Member Posts: 42 Arc User
    edited February 2021
    A similar situation. does not allow you to activate the bowler hat, as they explained to me, this is due to the fact that the bowler hat and the bear are considered by the game as one and the same mount https://ibb.co/Ntbbstd
  • regenerde
    regenerde Member Posts: 2,993 Arc User
    edited February 2021

    I got the mystic version of this mount from a lockbox. It is on the list of mounts for the character who claimed it and she is able to equip it. However, for my other characters, who claimed it from the "promo" menu and equipped it, it is not showing up on the list of mounts available.

    Well, bought the mythic mount today, and i have the same problem with it.

    Used the bought version without any problems, everything was granted properly to that character... but the pot bugged out on two other character i tried activating it on.
    First character got an error message stating that it already has everything from this "pack". Second character could activate the mount, but only received the equip power and nothing else.

    Would also be nice if they would change the animation from floating around to actually using it's feet while moving...
    Post edited by regenerde on
    I do believe in killing the messenger...
    Want to know why?
    Because it sends a message!