test content
What is the Arc Client?
Install Arc

Redeemed Citadel store - mount tokens disabled

vasile1991vasile1991 Member, NW M9 Playtest Posts: 69 Arc User
There's a bug with the Redeemed Citadel store when trying to claim the 5 weekly mount tokens.

I didn't claim anything yet for the entire week.
Yesterday, Milestone III was completed and this brought the possibility to claim mount tokens every week.

However, if you claim companion tokens first, mount tokens are disabled for purchase and you get the message "you have already purchased this item this week".

Viperion - DragonTribe guild leader.
Playing Healers (Cleric, Bard & Paladin) and DPS (Warlock & Wizard).


  • soronngsoronng Member, NW M9 Playtest Posts: 8 Arc User


    This happened to me today also.
    At the beginning I have 7 000 Zariels Favor before I bought anything.

    I purchased AD (Daily) first, then Preservation Wards (Weekly), next I bought 5 Companion Upgrade Tokens (Weekly). Then the Mount Upgrade Tokens (Weekly) got red and it shows the information that I bought this already.
    I left the shop window with 3 000 Zariels Favor and I could not buy the Mount Upgrade Tokens (Weekly).

    Could you fix this, please.

    If it takes longer to fix this, will we be able to purchase this in the future, I do not want to be short of this item if I could buy this, and because of bug I was not able to buy it.


    Screenshots from the game.




  • zimxero#8085 zimxero Member Posts: 876 Arc User
    Can the 'placeholder' be auctioned? or equipped?
  • manttazzmanttazz Member Posts: 48 Arc User
    hustin1 said:

    I was able to purchase it but I don't get any mount tokens. Instead I get an item with the placeholder icon in my inventory. I can't open it -- it simply says that I have all of the items in the package when I try to.

    Same problem here.
  • vordraxianvordraxian Member Posts: 68 Arc User
    edited October 2020
    I also ended up with no mount tokens anywhere on my character, but with a placeholder item in my inventory that cannot be unpacked.


    Eh, was going to post screenshots, but I can't get it to work. But it happened.

  • murphystoutmurphystout Member Posts: 72 Arc User
    On Monday, October 26 I bought Companion Tokens first and this disabled me from buying the Mount Tokens. I read the tooltip carefully and don't see anything indicating that this should be the case.
  • khaozhunterkhaozhunter Member Posts: 63 Arc User
    I bought the "5 mount upgrade tokens (weekly)" and spent 2000 zariel favors and got this pack in the inventory, when i try open this says "[Error] You already have all of the items in this package.", so, i spent 2000 zariel favors and didnt get my mount tokens :c
  • award9award9 Member, NW M9 Playtest Posts: 87 Arc User
    The same thing happened to me yesterday. I bought the companion tokens, then was unable to buy the mount token pack with the placeholder icon.
  • bigman99#8273 bigman99 Member Posts: 510 Arc User
    Yah the companion token reward are a complete ****show right now. After not being able to claim last week because of the issues posted by others above, now when I try to buy it this week, all I get the the damned "placeholder" icon(great quality control here Cryptic) in my inventory and a message saying I have already gotten all the rewards from this package this week. Though I have gotten nothing and it is literally the first part of the week.
  • nitocris83nitocris83 Member, Cryptic Developer, Administrator Posts: 4,495 Cryptic Developer
    Hey folks, thanks for reporting - I will escalate.
  • tamardltamardl Member Posts: 19 Arc User
    I also have this bug. I went to purchase my weekly items, and after I bought the companion tokens the mount tokens were greyed out - with the message that I already bought them. I know I didn't as I had the exact same amount of mount tokens as earlier. I also had plenty of favors. I even tried transferring the companion tokens into the bank just in case that might help - it didn't. So I came here and found this thread. Please let us know ASAP when this is fixed.
  • minionbobminionbob Member Posts: 31 Arc User
    Same here, placeholder in inventory, can't do anything with it. Something that makes me sad, when i questioned my alliance about it, they said it was a bug and that it was due to hampster quality control, which in turn caused another alliance mate to say "what do you expect? it's a free game, you get what you pay for!" I have heard this statement so many times, more times than "buying legendary mount with gold". This sort of outlook can't be what y'all are aiming for right?
  • kozi001kozi001 Member, NW M9 Playtest Posts: 876 Arc User
    Same here. You can buy multiple upgrade tokens but can't open it.
    Says Placeholder.

    But if you have bought pet token first you can't buy the other.
  • perlchaser#7290 perlchaser Member Posts: 13 Arc User
    I have the same problem. I was unable to purchase mount tokens last week. The first thing I did this week was attempt to purchase mount tokens and received the message. So I tried again and received the message again. Then, I found two placeholder mount token packages in my inventory and can continue to purchase from Zariel's store if I wish. The mount token packages also give me the error if I try to open them.
  • aelfgarmtaelfgarmt Member Posts: 14 Arc User
    I too have these placeholders. I should probably stop trying to buy them, but because they are weekly, I have still been trying.
  • rasputin#4674 rasputin Member Posts: 1 Arc User
    Add me to the list. I now have two "Place Holder" items in my inventory, rather than mount tokens.
  • darthpotaterdarthpotater Member, NW M9 Playtest Posts: 1,244 Arc User
    another inventory slot used :angry:
    Lescar PvE Wizard - Sir Garlic PvE Paladin
    Caturday Survivor
    Elemental Evil Survivor
    Undermontain Survivor
    Mod20 Combat rework Survivor
    Mod22 Refinement rework Survivor
  • aelfgarmtaelfgarmt Member Posts: 14 Arc User
    No update on this yet? This was first reported a week ago. I understand it might take longer to fix, but communicate with us, please.
  • theelusiveone#4954 theelusiveone Member Posts: 176 Arc User
    We got a patch today, yet this is still not fixed....
    This bug should have been extremely easy to find by quality control when testing milestone 3, but apparently us PC players are now the testers and the quality control department have been let go. At least that's how it seems. :angry:
    Guild Leader
    Neverwinter SOLO Alliance
  • amascus#1899 amascus Member Posts: 101 Arc User
    I have the exact same issue, i opened a support ticket and was directed to post here
  • kaelisskaeliss Member Posts: 1 Arc User
    Have the same problem but in my case i didnt get mount tokens and i dont have placeholders in my bags only my zariel favors are gone. I dont care about zariel favors but not getting mount tokens for two weeks in not so good. Not easy to get.
  • dillygirldillygirl Member, NW M9 Playtest Posts: 321 Arc User
    edited October 2020
    I have the same issue, but the other way around in buying order I think.

    When the milestone first became available, I had already bought my companion tokens for that week and I think but am not sure that I could get the companion tokens that time.

    This week I tried buying the mount tokens first. It ate 2000 Zariel's Favor - twice - and it gave me two of the placeholder icon items. One item might have been from last week, I am not sure about that. I am sure that it ate 4000 of my Favor. I attempted to buy them again after the mount tokens didn't show up in my currency tab, and only noticed that not only had I not gotten the Mount Tokens but also that it had deducted the amount of Favor twice.

    I really need either the mount tokens or the Favor back, I can't really afford to just lose that much Favor... Lots of stuff to buy!

    I also made a ticket about this and included a picture, #336038.

    Edit: I just noticed the Quality of Life thread had been reopened for a week! I wish I had known, adding this here then I guess: I would have just added fixing bugs in all class's powers. That would be really appreciated and remove a lot of frustration. AKA quality of life but probably not in the way you intended :P
  • ravenheart#6519 ravenheart Member Posts: 1 Arc User
    yes, and even a second purchase will not change to problem... never bought any of the other tokens and they are still just a place holder...
  • rheylinsark#1888 rheylinsark Member Posts: 54 Arc User

    Hey folks, thanks for reporting - I will escalate.

    Any ETA on fixing this problem, @nitocris83 ? The mount tokens are hard to come by in the first place, and now people have lost hard-earned favors for nothing.

  • shockerizershockerizer Member Posts: 78 Arc User
    Agreed. Waiting to hear what's up! :)
  • dillygirldillygirl Member, NW M9 Playtest Posts: 321 Arc User

    Hey folks, thanks for reporting - I will escalate.

    Any ETA on fixing this problem, @nitocris83 ? The mount tokens are hard to come by in the first place, and now people have lost hard-earned favors for nothing.

    This, and the tokens are only claimable a limited number of times, only until the event / milestones end. Missing a week due to a bug is a big deal imo. I hope they come up with a fix + a solution for everyone who missed out; I don't expect them to fix this on Halloween weekend ;) so it'll be after week reset.
  • seri#6446 seri Member Posts: 1 Arc User
    reported this and got this response and was directed here:

    "Thank you for getting back to us.

    We have received similar reports from other player and a Community Manager acknowledged the issue that was posted on the forum. Please be assured that we have made the development team aware of it and they're actively working on a fix. Once we have an update, we'll let the community know by posting it on our forums and news page."
  • bigman99#8273 bigman99 Member Posts: 510 Arc User
    So another week goes by and still no fix. Since this is a limited time event, those tokens cannot be regained once lost, we can't "go back" and get them later. An escalation of the problem was due the day it was reported. It needs to be a "lets fix this now" situation.
  • serpeer#6400 serpeer Member Posts: 49 Arc User
    @nitocris83 , news?
  • nitocris83nitocris83 Member, Cryptic Developer, Administrator Posts: 4,495 Cryptic Developer
    Hey folks, we have a fix for packs that cannot be opened. Fix is being tested but we hope to have it live soon.

    As a reminder, you can only get one pack per week. We are aware of some players obtaining multiple packs due to click/lag reaction time but only one would be valid for opening.
Sign In or Register to comment.