test content
What is the Arc Client?
Install Arc

Warlock and wizard camera/at-wills bugs still not fixed nor addressed

raven#3338 raven Member Posts: 290 Arc User
edited December 2019 in Bug Reports (PC)
These two classes suffer a lot of bugs related especially to camera work but not only, one of them being stuck in At-Will animation even if I don't press mouse button. It involves only at-wills. Also, randomly, especially wizard is activating at-will while passing by mobs, thus engaging them in fight, without any action from my side. Another thing is at-will animation active while the fight is over, as if at-will was targeting something invisible but targetable, the only way to stop it is using blink/shadowslip.
Warlock: camera shake while in shadowslip, camera shake sometimes is present after shadowslip ends.
At times, camera bug appears especially on wizard when changing maps (such as LoMM entering Cold Run area or changing master espeditions maps) - the screen goes black after entering new map and camera slides through whole area/map/location/textures which takes several seconds before it sets up properly focused on character. It appears randomly so I had no chance to record it, would need to record a large potion of gameplay and cut it but I hope you get what I mean.

I really, really appreciate if someone took a look into this, it's annoying and makes gameplay not fun.

«1

Comments

  • aganwayaganway Member Posts: 269 Arc User
    edited December 2019
    I have myself reported in this forum how hitting W was setting off my at-wills and someone else verified it was happening to them as well. It doesn't happen to me when I am running past something but happens to me when I am just about to run into a battle. It doesn't happen a lot but it does happen from time to time and is extremely annoying to the point of being upsetting. I will hit W to run towards a mob and instead of moving/running I start to fire off at-wills which causes them to engage and run to me before I am ready. It's even more disconcerting to me because my play style has never been to hit at-wills first I always start off with an encounter (without fail) so it's even more jarring to me.
  • aganwayaganway Member Posts: 269 Arc User
    and yea I'm a wiz, sorry left that out.
  • nitocris83nitocris83 Member, Cryptic Developer, Administrator Posts: 4,316 Community Manager
    Thread has been shared with the rest of the team for review/investigation.
  • skingdev#1102 skingdev QA Lead on NW Member, Cryptic Developer Posts: 77 Cryptic Developer
    We are currently trying to reproduce this one in house. Any additional information would be very helpful.

    - SKing
  • rikitakirikitaki Member Posts: 810 Arc User
    Let me just add that random chain triggering of at-will powers and being stuck in it was a long-term GWF speciality - back in the heyday of Dragon-runs in the WD you could quite often see those "less intelligent beings" walk in the straight line as the surestrike preached. Nowadays... even after renaming them barbarians they still get stuck in that silly dance once in a while, but it is no longer every other minute like it used to be.
  • methuselasmethuselas Member Posts: 275 Arc User
    edited January 2020

    These two classes suffer a lot of bugs related especially to camera work but not only, one of them being stuck in At-Will animation even if I don't press mouse button. It involves only at-wills. Also, randomly, especially wizard is activating at-will while passing by mobs, thus engaging them in fight, without any action from my side. Another thing is at-will animation active while the fight is over, as if at-will was targeting something invisible but targetable, the only way to stop it is using blink/shadowslip.
    Warlock: camera shake while in shadowslip, camera shake sometimes is present after shadowslip ends.
    At times, camera bug appears especially on wizard when changing maps (such as LoMM entering Cold Run area or changing master espeditions maps) - the screen goes black after entering new map and camera slides through whole area/map/location/textures which takes several seconds before it sets up properly focused on character. It appears randomly so I had no chance to record it, would need to record a large potion of gameplay and cut it but I hope you get what I mean.

    I really, really appreciate if someone took a look into this, it's annoying and makes gameplay not fun.

    @skingdev#1102, @mikusquared#1439

    Check the movement code, more specifically your transition/tween animation code. I use L/R mouse to move forward and backwards, M4/M5 for left/right for strafing. Q,W, E are used for Encounters and A and D are for at-wills. I'm not seeing this problem at all. I use the same keybinds for my Warlock, as well and I see neither of my toons fire off At-Will animations during movement, when I click a mouse button.

    The reason I mention this is I suspect there may be a bug with the tween animations. I've seen several times, where both toons and mobs animations seem to break, usually during specific events relating to physics (I'm not sure if you are using a specfic physics engine or not.) For example, if you get hit with multiple ranged attacks, sometimes the transition animation will break and instead of being dismounted, the mount rig will break and the mount will just slide across the geo. Typically, once you get out of combat, it resets itself back to normal. Also, falls from a good distance will also break the animation/rig. Sometimes the joints of the rig will gimbal lock and drag limbs with the animation. I can try and grab a video, but it seems to be along the shoulders and hips. The entire body will just lock up.

    The best place to see this is to run, say a guard drake mount down from Dragon Hill in Strongholds. if you break to the immediate left and move down the hill, either jump off the hill, but still moving forward or let your toon get hit by the group of mobs there. That's the place I see it the most.

    Hope it helps.

    [EDIT] - Oh, I use S for Dodge, if needed.
  • methuselasmethuselas Member Posts: 275 Arc User
    edited January 2020
    rikitaki said:

    you could quite often see those "less intelligent beings" walk in the straight line as the surestrike preached. Nowadays... even after renaming them barbarians they still get stuck in that silly dance once in a while, but it is no longer every other minute like it used to be.

    Yeah, a couple of mobs in Strongholds do this. Looks like they got a hernia from trying to do a dead lift, but it's their walk animation. XD

  • xavior44xavior44 Member Posts: 153 Arc User
    edited January 2020

    Greetings,

    We have a few questions regarding the at-will issue. Btw, you guys are champs for dealing with it.

    • Are you noticing this on Warlock as well, or are you seeing it specifically on Wizard?
    • Is there any specific area/queue that you are noticing this happen in?
    • Are you in a party with others when this happens?
    • How often are you seeing this? Is it usually when you're traveling to quests or is it when you're in the middle of doing a quest after fighting for a few already?
    • Which at-wills fire? The first at-will slot? The second at-will slot? Both in succession?
    • When the at-wills fire, are you holding down W or just moving naturally?
    • Do you have any other Encounter Powers/Buffs active when this happens (ex. Shield)?
    I also have an additional question regarding Shadow Slip issue you're mentioning. Would you mind sending us a video when this occurs?

    Additional information regarding this would be much appreciated! And to note, several other issues mentioned have been confirmed and entered into the database. Thanks much guys!

    - Mikusquared
    I strongly believe its due to warlock dodge and the delay that's there is between say dodge 1 and dodge 2 back to back. If your At-willing and try to animation cancel with hellish rebuke/shadow slip, it seems to cause this more times then not. Especially if your spamming it with small bursts of shadowslip
  • burnthedead#7732 burnthedead Member Posts: 69 Arc User
    I noticed it when shadowslip was draining my stamina, you are supposed to get diminishing returns as the stamina bar empties. Maybe it's an auto correct to lower speed or something, but camera has stuttered like that since early mods.
  • aganwayaganway Member Posts: 269 Arc User

    Greetings,

    We have a few questions regarding the at-will issue. Btw, you guys are champs for dealing with it.

    • Are you noticing this on Warlock as well, or are you seeing it specifically on Wizard?
    • Is there any specific area/queue that you are noticing this happen in?
    • Are you in a party with others when this happens?
    • How often are you seeing this? Is it usually when you're traveling to quests or is it when you're in the middle of doing a quest after fighting for a few already?
    • Which at-wills fire? The first at-will slot? The second at-will slot? Both in succession?
    • When the at-wills fire, are you holding down W or just moving naturally?
    • Do you have any other Encounter Powers/Buffs active when this happens (ex. Shield)?
    I also have an additional question regarding Shadow Slip issue you're mentioning. Would you mind sending us a video when this occurs?

    Additional information regarding this would be much appreciated! And to note, several other issues mentioned have been confirmed and entered into the database. Thanks much guys!

    - Mikusquared
    I have had this happen in various places there doesn't seem to be any pattern to it.

    I've had it happen both when soloing and when in a dungeon in a party after queing for a pug queue. The last couple of times it happened were while I was soloing a Master Expedition and when I was in Castle Never.

    It doesn't happen very often. In the past 3 months I think it happened for me about 5 times but I'm guessing as I don't keep records. It is totally sporadic, it can all behave perfectly for ages then boom out of the blue it happens.

    Main at-will is always the one which fires, left mouse button, never the other one. As Arcanist I have magic missile as main at-will, ray of frost on 2nd.

    For me, I am standing still, I hold down W to run forward to get into position and at-will fires instead and I stand still hitting the enemy without moving forward. Being able to hit from 80 feet away means I aggro them from a safe position unintentionally. I don't recall ever having been running and pressing W and then it triggered at-wills while moving. In all cases I was standing still, went to run forward and the at-will went off instead. Running is totally replaced by at-will, they don't both happen together.

    I don't use sheild (well extremely rarely as a last-ditch attempt at getting through a solo thing) and I have never had sheild up when this thing triggers.


    While we're here, I noticed Steal Time has been acting better lately and not failing to trigger as often as before, but it is still failing here and there and still not 100% failproof. I've been off for a week or so but am going in tonight, I will keep an eye on Steal Time and see how many times it fails and report back in the Steal Time bug thread.
  • demenoss#9306 demenoss Member Posts: 187 Arc User

    Greetings,

    We have a few questions regarding the at-will issue. Btw, you guys are champs for dealing with it.

    • Are you noticing this on Warlock as well, or are you seeing it specifically on Wizard?
    • Is there any specific area/queue that you are noticing this happen in?
    • Are you in a party with others when this happens?
    • How often are you seeing this? Is it usually when you're traveling to quests or is it when you're in the middle of doing a quest after fighting for a few already?
    • Which at-wills fire? The first at-will slot? The second at-will slot? Both in succession?
    • When the at-wills fire, are you holding down W or just moving naturally?
    • Do you have any other Encounter Powers/Buffs active when this happens (ex. Shield)?
    I also have an additional question regarding Shadow Slip issue you're mentioning. Would you mind sending us a video when this occurs?

    Additional information regarding this would be much appreciated! And to note, several other issues mentioned have been confirmed and entered into the database. Thanks much guys!

    - Mikusquared
    Wizard Report:
    I am NOT having the same exact issue with at-wills firing when walking. I find that 'Ray of Frost' (second slot) gets stuck on during fights -- usually during DF and also running MEs, once/twice in randoms (been awhile though). I am in party when it happens. I don't usually use Shield - so not active.

    Not much, but hope it helps...
    Guild: Noble Misfits
    Silky Pan'teeze: Drow Wizard --- Madres de Nasae: Half-elf Rouge
    Kepler: Human Paladin --- Demenoss: Dragonborn Barbarian
    Divine Pan'teeze: Drow Cleric --- Nikki Sharparrow: Human Ranger
  • hawkeyelhawkeyel Member Posts: 389 Arc User
    As far as Shadowslip on the Warlock goes it had its priority lowered some Mods, back that makes it delay even if an At-Will is cast. This has been an issue for some time, felt it worked better before this change. Shadowslip should work in much the same way dodge does on others classes and have priority over all other powers again.
  • thanatos#8671 thanatos Member Posts: 3 Arc User
    > @"mikusquared#1439" said:

    > I also have an additional question regarding Shadow Slip issue you're mentioning. Would you mind sending us a video when this occurs?

    > - Mikusquared

    I now have a video of Shadow Slip getting twitchy. I just need a way to send it to someone.
    - Thanatos, Level 54 Warlock
  • aganwayaganway Member Posts: 269 Arc User
    Seeing a new mod is about to drop they are probably busy atm.
  • aganwayaganway Member Posts: 269 Arc User
    Oh I def agree, hopefully the new top banana is reading these forums and will give them a kick up the rear on it. One of the main objections long-term players of this game have is that there are bugs from so long ago which are still not fixed, and they can't say that it's because no-one told them. I often get annoyed that they release new content while there are still outstanding bugs from before, because we all know that with a new mod, there are always new bugs to be fixed. So yea, hopefully they will get off their rears and fix the stupid things so we can enjoy the game we pay good money for. All I was saying was that with the new mod dropping, they will be very consumed with last-minute stuff for that and it will be one of their busiest times so to be expected that everything else gets put aside for the time being.
  • skingdev#1102 skingdev QA Lead on NW Member, Cryptic Developer Posts: 77 Cryptic Developer
    Lots of new information from you all. I'll poke @mikusquared#1439 on Tuesday when we get in to go through this thread and post any updates.

    Thanks everyone

    - SKing
  • kurdain1kurdain1 Member Posts: 16 Arc User
    edited January 2020
    @skingdev#1102
    @nitocris83
    @mikusquared#1439

    Nito is already aware of this but several camera tracking issues are also plaguing other classes with movement or movement speed buffs.
    My thread about the issue on my fighter, complete with video (a lot more to offer if requested, files are LARGE).

    It's incredibly bad and surfaces within minutes in any dungeon, consistently, details contained:
    https://www.arcgames.com/en/forums/neverwinter#/discussion/1253108/chase-camera-shaking/p1

    Thanks,
  • gabrieldourdengabrieldourden Member, NW M9 Playtest Posts: 1,212 Arc User

    These two classes suffer a lot of bugs related especially to camera work but not only, one of them being stuck in At-Will animation even if I don't press mouse button. It involves only at-wills. Also, randomly, especially wizard is activating at-will while passing by mobs, thus engaging them in fight, without any action from my side. Another thing is at-will animation active while the fight is over, as if at-will was targeting something invisible but targetable, the only way to stop it is using blink/shadowslip.
    Warlock: camera shake while in shadowslip, camera shake sometimes is present after shadowslip ends.
    At times, camera bug appears especially on wizard when changing maps (such as LoMM entering Cold Run area or changing master espeditions maps) - the screen goes black after entering new map and camera slides through whole area/map/location/textures which takes several seconds before it sets up properly focused on character. It appears randomly so I had no chance to record it, would need to record a large potion of gameplay and cut it but I hope you get what I mean.

    I really, really appreciate if someone took a look into this, it's annoying and makes gameplay not fun.

    Also rangers have the at-will issue. Clear the ground often starts on its own and you can't get out of it.
    Le-Shan: HR level 80 (main)
    Born of Black Wind: SW Level 80
  • aganwayaganway Member Posts: 269 Arc User
    I'll just throw this in here seeing this thread is being actively monitored (and ty for letting us know, appreciated, the other thing players get upset about is no updates/feedback on existing issues and to us it appears no-one cares and nothing is being done, we just like being kept informed of progress in an honest and timely way, that's all) Steal Time is still not proccing everytime without fail (which it def should be, it's an encounter and all encounters should work 100% of the time, yes?) it seems to be something connected with the counter being dodgy but not sure. Symptom is when activated, avatars hands will go up as if to start the spell, beginnings of sound effect will start, then hands immediately go down to sides, encounter does not happen and counter goes down to something random like 6 seconds or whatever and then counts down from there after which you are free to try it again. Success rate of this very important encounter (as an Arcanist Wizard there are limited AOE powers to choose from) is not acceptable, as far as I know encounters are not RNG. I made a thread about it elsewhere in bug section ("Something is going funny with Steal Time" or similar), it has been doing this for ages and ages. It seems to have improved slightly lately (was extremely bad before with a more or less 50/50 chance of working and this has improved a bit) but there are still more than enough instances of it not happening to be of serious concern and needing priority attention. All you have to do is equip the power and go play with it (I use it on TAB but I guess it does it on all keys) and you will soon see what is going on. Thanks. :-)
  • modestmouse75modestmouse75 Member Posts: 61 Arc User
    Glad that this is being looked at, for me personally I am on my Warlock and it happens in various areas. Last night I was streaming and it happened while I was doing Stardock Quests,(over and over), anytime I shadow slipped it happened. For the riding around on mount, then suddenly I am fighting something, again happens randomly.

    I find it most disturbing when I am in a dungeon, IE should let tank go first, I randomly am pressing only the W and suddenly my at-wills go off. I can only say "I didn't do it I swear". So yes please do keep us informed because this does affect our game-play in a "not so fabulous way" and is very frustrating especially the at-wills going off.
    image
    SW:Mouse
    OP:MisfitMouse
Sign In or Register to comment.