test content
What is the Arc Client?
Install Arc
Options

Devil's Council quest bug

mjonismjonis Member, NW M9 Playtest Posts: 146 Arc User
edited January 2014 in Bug Reports (PC)
The Devil's Council quest is bugged. I've defeated all the kidnappers and the quest will not advance. I think it may have something to do with the fact that the kidnappers came into the other room and died there?
Post edited by Unknown User on

Comments

  • Options
    chizbochizbo Member Posts: 1 Arc User
    edited June 2013
    I find the same thing. I will try abandoning quest and starting it up again, then killing the final group in the last room.

    EDIT: confirmed, abandoning and then re-doing quest and killing last group in the final room with Councilman Graves worked
  • Options
    yablorkinyablorkin Member, Neverwinter Beta Users, Neverwinter Hero Users Posts: 7 Arc User
    edited June 2013
    Thanks for this. Confirming this is still an issue. Dropping the quest and going back and killing them in the final room worked for me.
  • Options
    nztrissnztriss Member Posts: 1 Arc User
    edited January 2014
    Apparently still bugged but I didn't have to abandon and pick up the quest again to fix it. Just exit the house then go back in and everything inside re-spawns. Then kill the last group inside the room with the councilman to finish the quest.
  • Options
    beckylunaticbeckylunatic Member, NW M9 Playtest Posts: 14,231 Arc User
    edited January 2014
    Hm, yes this was still bugged recently. If the devils don't die in the correct room, Graves won't talk. But leaving the building and coming back does help.
    Guild Leader - The Lords of Light

    Neverwinter Census 2017

    All posts pending disapproval by Cecilia
Sign In or Register to comment.