test content
What is the Arc Client?
Install Arc

Bruenor's Helm visuals...

alfared#9239 alfared Member Posts: 38 Arc User
Are you guys aware that the visuals on Bruenor's Helm are MIA since the Ravenlaunch?
It seems that the effects are active....but there is absolutely no visuals at all...
...it renders this most awesome of artifact basically uselerss.,...especially in party settings....solo i can use it...cause i knmow where i position it...
...but even then its less than ideal....
Now I know that it is not a very popular artifact...but it is my favorite ever since i brough it to mythic level....
....and i needed 69 pres wards to convert from legendary to mythic...
...pretty bummed out to be out of my main artifact...
...its my 4th attempt at getting your attention to the issue...
...2 messages in the Ravenloft launch issue forum...1 in the latest patch note(july 3rd)...and this 1 message that you read...
...it realy affects my play....
....i havn't read anything about it anywhere in the forums....
....i hope you can (at the very least) acknowledge the issue....if not fix it right away!
i must admit its pretty frustrating...when you kow how to use it....its a very powerful artifact....
...and i miss being able to turn the tide of battle with it!....it was a lot of effort to bring it to mythic....i wnt to be able to use it....
...ARE YOU GUYS EVEN AWARE?
....losing faith in your claim of reading all the messages posted : (
...it s my 4th attempt....hopefully it gets the attention it deserves!

Thank You

Best Answer

  • alfared#9239 alfared Member Posts: 38 Arc User
    Answer ✓
    Eh beh!....seemingly after verifying with other players....it would seem that this is an issue that only i have...they say they could see the circle and rainbow....so sorry for doubting you guys....doesnt solve my problem...kinda sucks that 1 of the only players using this is the 1 who gets the issue...some kind of ironic!...but i understand why the issue was not aknowledge!....keep up the good work! played with my graphic settings to no avail....ill contact support and see what they say!
Sign In or Register to comment.