Pet Gone :(

lovedru12114
lovedru12114 Posts: 9 Arc User
edited February 2011 in Technical Support Zone
After hatching my emberite pet its gone >.<

Pls help me :(
Post edited by lovedru12114 on

Comments

  • merilwen
    merilwen Posts: 0 Arc User
    edited February 2011
    More people seem to be experiencing this. I have the same problem :'D
    ~rawr
  • cezzyaku
    cezzyaku Posts: 7 Arc User
    edited February 2011
    After hatching my emberite pet its gone >.<

    Pls help me :(

    Same happened to me..
  • mythnst0rm
    mythnst0rm Posts: 3 Arc User
    edited February 2011
    After hatching my emberite pet its gone >.<

    Pls help me :(

    Same problem here emberite was bought then went through about 27 minutes waiting
    for it to hatch. It said it hatched. Somewhere between the pet tab to my inventory it just
    vanished. Was wondering if this is where we need to report it or is there a place to
    submit a ticket?
  • drakenfyre
    drakenfyre Posts: 2,614 Community Moderator
    edited February 2011
    mythnst0rm wrote: »
    Same problem here emberite was bought then went through about 27 minutes waiting
    for it to hatch. It said it hatched. Somewhere between the pet tab to my inventory it just
    vanished. Was wondering if this is where we need to report it or is there a place to
    submit a ticket?

    http://support.perfectworld.com/

    you can send a ticket to support
    Swordsman Moderator, Forsaken World Moderator, Jade Dynasty Moderator
    I do not have the staff on speed dial
    Insanity Runs Downhill
    2v3ld35.jpg
  • djdread
    djdread Posts: 5 Arc User
    edited February 2011
    43 mins I was all like "Woot!!!" then no pet =_=
    A guy killed me with a Spork the other day. It's ok, I got better.
  • kamillka
    kamillka Posts: 1 Arc User
    edited February 2011
    The same :( my 400 leaf just waste
  • lovedru12114
    lovedru12114 Posts: 9 Arc User
    edited February 2011
    i already got the ticket i do hope they will work on it as soon as possible :mad:
  • danrocco
    danrocco Posts: 36 Arc User
    edited February 2011
    Ok so it happened to me too.... should check forums before buying stuff... seems it disappeared after it was ready to hatch clicked and gone :(
  • kensharma
    kensharma Posts: 0 Arc User
    edited February 2011
    Same issue here.
    Here To Live, Love, Joy, And Rock The Game.

    Not Here To Argue. Not Here To Fight.

    Here To Be My Best, Using All Of My Might
  • partyzan
    partyzan Posts: 2 Arc User
    edited February 2011
    i bought it twice, nd waited to hatch, now i lost 800 leafs :(
    image.php?u=38188641000&type=sigpic&dateline=1325901931
    Duelist 103lvl