test content
What is the Arc Client?
Install Arc

"The Kings Quest" Possible Bug.

fenrir9394fenrir9394 Posts: 1 Arc User
edited April 2012 in Quest Tips
For The Quest "The Kings Quest" , i have followed all steps and actions regaurding this quest, i am possitive that perhaps the game may of bugged whilst trying to hand in the quest and i have not recieved another quest in advance..
which brings me to the point of, this quest is an un - Cancelable quest which means i cannot drop the quest and start all over again. all my level requirements meet as i am level 71 and have made sure of this.
I Am Stuck on the part where i must Return the sword, but the quest to gain the sword is un takeable?
I have tried searching this situation on Forums, and have gotten nowhere :confused:

Anyone else who may have experienced this issue please add a note bellow :)

Thanks

Comments

  • manavichmanavich Posts: 6 Arc User
    I have been waiting for this to get fixed the entire time . main quest failure . I got the quest , I killed the werewolf got the sword then the npc wouldn't take it . I trashed the sword tried to cancel the quest its three parts one part canceled ,the other two wont , I just killed the werewolf again and of course no sword , the npcs wont restart the quest . now im level 81 and still cant do the main quest .
    I got to 81 just by logging and doing quests for reo , i cant follow the main quest line ,so i cant play . i throw all the loggin rewards away because i have no use for them i haven't been able to play for years ,im not a bot i don't want to bash some dummy , im non pvp , i want to play . i need the main quest line to work . don't refer me to support . you should have left me in forsaken harbor where i belonged . there are so few quests i can do because i am 1 person i run 1 machine , i have 1 account ,i have 1 toon . please find a way to fix the main quest so it will cancel or restart or void it because ive out leveled it .
    ill have better luck in the forum than with support .lol thanks . ( world shaper ) ... i didn't necro i just got lots of patience . : )
  • manavichmanavich Posts: 6 Arc User
    aw i cant fix typos in the forum ? freedom harbor... i meant to say freedom harbor ...i cant believe i cant edit that omg .....why cant we edit mistakes ? recommends forum upgrade ... lol , bashes arc ...says it just wont die .
  • tranquilisedtranquilised Posts: 1 Arc User
    have you tried using the sword with right click first? Worked fine for me a couple of days ago
Sign In or Register to comment.