test content
What is the Arc Client?
Install Arc

arc launcher wont start and cant install as wel

du to my pc having met its maker i had to resort to my lab top to play sto and found out some how in my absence arc launcher decided to no longer function i have updated java and the thing i seven redownloading it from the site wont do it , if i click installl nothing happend except asking permision to run arc but then nothing? specialy anoying sinc ethis might be the first time i missed out on the winter event ship from sto thanks to this glitch :-(


  • stargazer99999stargazer99999 Posts: 2 Arc User
    wierd thing is i tryed to go outside arc launcher and at least now sto is updating !
  • Had to reinstall Arc. Was playing my game earlier and had to move things in my computer to allow more space. Now while reinstalling Arc, I get an error message: TARGETDIRFiles - The system can not find the file specified. Please help as I want to reinstall and begin playing again. I know it is not my laptop as it is a new gaming system and I was just playing the game on it.
  • i am new here and on first time install get this also error message: TARGETDIRFiles - The system can not find the file specified.
    not been able try any games times like this we need game installers
  • I'm new here, so I can't start a new thread. My issue is kind of similar to this one and I hope someone can help.

    I woke up one morning and put in my username and password to Arc. "Your sign in information does not match our records. Please try again". <-- huh... okay, I put my password in 3 more times, making sure I type it correctly each time. "Your sign in information does not match".

    Well, looks like I'll need to hit "forgot user name and password". Sigh... put in my email. They send a link. "Your username is SwordoFlame. Click this link to make a new password" <-- which I did... something very short and easy.

    Then I get the screen "your password has been changed". Okay good! Now then... go to Arc, sign in, type the new password....

    "Your sign in information does not match our records. Please try again." <-- What?? I *KNOW* I'm typing it right this time! I try again... same thing.

    I go back and try to make ANOTHER password, this one even simpler. "Your password has been changed". Go into Arc, get the same exact thing... "Your sign in information does not match". I go to bed.... thinking maybe it takes time to register in the system. Woke up this morning and am still getting that same message.

    I wanted to test something... so I tried changing password again, only this time I tried changing it to the exact same password I put in last time. Normally the system won't let you do that... but in this instance, it didn't say anything other than "password changed". So either the system lets you change your password to the same exact one you were using before, or it's seriously not detecting something.

    I can't use Arc at all until this is fixed. I sent an email to customer service yesterday but haven't heard back yet. Hope someone can look into this.
Sign In or Register to comment.