Error installing launcher

I've been trying to install the launcher for a few days now. Every time it gets to the folder option I hit next, it starts to install then I get a feature transfer error TARGETDIRFiles The system cannot find the file speciefied.
I've even tried making a new folder for it on another drive and installing but I get the same error. Help fixing this would be appreciated


  • kablassaa#9696
    kablassaa#9696 Posts: 1 New User
    I have the same problem, did you find a solution?
    Windows 10 here
  • artemis#2494
    artemis#2494 Posts: 1 New User
    I have had to do a complete reinstall of windows 10 on my lap top. After this, I have been unable to install ARC onto the computer. after the download, an initialisation screen comes up, then nothing else happens. Is there anyone out there who can offer assistance here? I have spoken to windows support and they did the clean install. ARC support were unable to provide anymore help than what id already tried on their help forums.
  • mcdares
    mcdares Posts: 1 Arc User
    I have the same problem, did you find a solution?
    Windows 10 here too.
  • axsom0570
    axsom0570 Posts: 1 New User
    Has anyone found a solution to this issue? I've just built a new PC with NEW W10 Pro install and am having the exact same issue...
  • rebelfay
    rebelfay Posts: 1 Arc User
    I've tried to install on two different new computers and even though they use different anti-virus, they both stop the install and say it is a virus. Is that the same thing happening to you?