test content
What is the Arc Client?
Install Arc

Involuntary reroute to ARC from perfectworld.vanillaforums.com

gulberatgulberat Posts: 400 Arc User
Someone seems to have switched on a forced reroute if you access the forums through http://perfectworld.vanillaforums.com.

Anyone figure out any ways to prevent this unwanted browser hijacking from occurring? Note that the Latest Post feature WILL NOT WORK when the ARC shell is active, so that makes this a particularly nasty hijacking.

EDIT: While clicking that link temporarily stops the redirect, as soon as you hit Home or hit Reload, the browser hijacking recurs. Just typing that URL in your browser will NOT work and will cause you to be redirected immediately.

Christian Gaming Community Fleets--Faith, Fun, and Fellowship! See the website and PM for more. :-)
Proudly F2P.  Signature image by gulberat. Avatar image by balsavor.deviantart.com.

Comments

  • frtoasterfrtoaster Posts: 2,566 Arc User
    edited July 2015
    Yes, they've started redirecting perfectworld.vanillaforums to www.arcgames.com/en/forums without fixing any of the problems with the embedded iframe. I kind of suspected this would happen.
    frtoaster wrote: »
    You can work around the problem by going directly to perfectworld.vanillaforums.com. Part of me is afraid that they'll disable this workaround if they find out that too many people are doing it. Of course, disabling the workaround would show more concern for whether people are doing things the "approved way" than the underlying problems that caused people too look for workarounds in the first place.
    Post edited by frtoaster on
  • nrglgnrglg Posts: 347 Arc User
    edited July 2015
    Solution for now...
    http://perfectworld.vanillaforums.com/discussion/comment/12592776/#Comment_12592776

    This was something they should've waited on until the loading issues in conjunction with the iframe were fixed.

    GAME FORUMS (Direct Link & Arc Frame)
    Hub | Arc | PWI | FW | NW | STO | SO | BLR | JD | BOI | CO | WOI
    Hub | Arc | PWI | FW | NW | STO | SO | BLR | JD | BOI | CO | WOI
    Forum Enhancements and Visual Improvements
    (Greasemonkey/Tampermonkey and/or Stylish required)
    PWI vBulletin Forum Data Dumps and Backups
  • guljarolguljarol Posts: 469 Arc User
    edited July 2015
    gulberat wrote: »
    Anyone figure out any ways to prevent this unwanted browser hijacking from occurring? Note that the Latest Post feature WILL NOT WORK when the ARC shell is active, so that makes this a particularly nasty hijacking.

    Yeah, I just found out it doesn't, and came here to do exactly the same: to report this.
    nrglg wrote: »

    It doesn't seem to work for me. Maybe I need to restart the browser (FF).


    ETA: Nope, still doesn't work after restart. :(

  • gulberatgulberat Posts: 400 Arc User
    I may have gotten it to work. I won't say for sure until I've seen it work for several pages, but let me know if you need me to send a screenshot of what I did. Of course I'm running Win 8.1, so I can't say if that would make any difference...

    Christian Gaming Community Fleets--Faith, Fun, and Fellowship! See the website and PM for more. :-)
    Proudly F2P.  Signature image by gulberat. Avatar image by balsavor.deviantart.com.
  • guljarolguljarol Posts: 469 Arc User
    gulberat wrote: »
    I may have gotten it to work. I won't say for sure until I've seen it work for several pages, but let me know if you need me to send a screenshot of what I did. Of course I'm running Win 8.1, so I can't say if that would make any difference...

    I'd appreciate a screenshot. I experimented some, but no results. It still redirects me to ARC frame.

  • gulberatgulberat Posts: 400 Arc User
    guljarol wrote: »
    gulberat wrote: »
    I may have gotten it to work. I won't say for sure until I've seen it work for several pages, but let me know if you need me to send a screenshot of what I did. Of course I'm running Win 8.1, so I can't say if that would make any difference...

    I'd appreciate a screenshot. I experimented some, but no results. It still redirects me to ARC frame.

    OK, I went to Filter Preferences in AdBlock Plus and created a new filter group to make it easier for me to see where I was adding custom stuff. Then in the box on the right, I pasted the filter nrglg provided.

    http://s1300.photobucket.com/user/NerysGhemor/media/Custom Filter_zpsieiyjbnx.png.html

    After I pasted that in, I hit "Add Filter" to make sure the filter saved. See if that helps. :)

    Christian Gaming Community Fleets--Faith, Fun, and Fellowship! See the website and PM for more. :-)
    Proudly F2P.  Signature image by gulberat. Avatar image by balsavor.deviantart.com.
  • guljarolguljarol Posts: 469 Arc User
    edited July 2015
    I had the same, but for the sake of clarity, I also created a separate group for ARC Forum. Still no-go. Doesn't work.

    Where you have 24 hits, I have constantly 0.

    I suspect I have something else that is in conflict... I'll keep trying to find what's wrong, because right not the forum is a pain to use.



    ETA:
    I had "perfectworld.vanillaforums.com^$document" blocked. I unblocked it, and now blocking the redirecting to the frame seems to work.
    Post edited by guljarol on

  • nrglgnrglg Posts: 347 Arc User
    That filter was for Adblock Plus. I don't know if it works in regular adblock. Whatever the case, Asterelle's extension has added redirect blocking, so I'd say that you should instead use that. Mine was a 1 minute fix whereby I looked for the source of the problem and blocked it.

    GAME FORUMS (Direct Link & Arc Frame)
    Hub | Arc | PWI | FW | NW | STO | SO | BLR | JD | BOI | CO | WOI
    Hub | Arc | PWI | FW | NW | STO | SO | BLR | JD | BOI | CO | WOI
    Forum Enhancements and Visual Improvements
    (Greasemonkey/Tampermonkey and/or Stylish required)
    PWI vBulletin Forum Data Dumps and Backups
  • guljarolguljarol Posts: 469 Arc User
    I use AdBlock Plus. The problem was with "perfectworld.vanillaforums.com^$document" being blocked, or at least unblocking it made this filter work.

    I have the extension installed, so if it's there, I'll use that instead. :)

    Thanks :)

  • gulberatgulberat Posts: 400 Arc User
    Glad it worked! I didn't even notice the "24 hits" in the picture. Guess that screenshot was worth something after all! :)

    Christian Gaming Community Fleets--Faith, Fun, and Fellowship! See the website and PM for more. :-)
    Proudly F2P.  Signature image by gulberat. Avatar image by balsavor.deviantart.com.
  • angrytargangrytarg Posts: 165 Arc User
    Thank you very much for that adblock filter, it works like a charm 3cf12d2518d3678c56fe39380a68b386.gif

    I'm just not sure this is supposed to be a "bug". I would suspect they want you to use the arc page. While doing so, however, we users face a number of significant disadvantages:

    1. Arcgames page is much, much slower
    2. Thread titles in open tabs are replaced with "arc games" header
    3. latest post doesn't work
    4. "double login" issues, redirect issues
    5. arcgames has a number of trackers running in the background whereas the direct forum URL is tracker-free

    And those are only things I noticed after a few minutes, I'm sure there is more to it as well. PWE really has to watch out here - Vanilla forums are a cheap (I'm sure about that) 'solution' but lack a lot of features and functions commercial and established forums offer. And they have to watch out that they don't break user workarounds on a regular basis because right now we have to make these forums work without bigger privacy, security and comfort issues on our end. If PWE breaks/locks those mods at least I have to stop using the forums after almost five years. Maybe others will as well. It doesn't shed a good light on the company and - in consequence - on the companies providing the games. I know that Cryptic isn't affiliated with the forum administration any more - but their reputation will suffer as well.
    <center>223.gif</center>
    <center>"No. Men do not roar. Women roar. Then they hurl heavy objects... and claw at you." -Worf, son of Mogh</center>
    <center>Vanilla is nice... we're talking about ice cream, right? ...
    Get the Forums Enhancement Extension!</center>
  • katamaster81899katamaster81899 Posts: 869 Arc User
    Seems as though Asterelle's block for the redirect no longer works for me D:​​
    dulopa4e1d9.png
    XB1 Thaumaturge PVE CW Build || NW_Legit_Community Moderator || Axios Guild Leader || Neverwinter Trade Forum Moderator
    Check out my foundry, titled "Akro's Gone Wacko", featuring our ex-CM Akromatik!: NW-DL8J7BY5T

    Erza Moonstalker | Lara Moonstalker | Julie Marvell | Erza Moonhunter | Annie Hellangel | Jenn Moonstalker
  • asterelleasterelle Posts: 368 Arc User
    Seems as though Asterelle's block for the redirect no longer works for me D:
    It's working on all my browsers. Are you able to reproduce the error? ​​
  • katamaster81899katamaster81899 Posts: 869 Arc User
    asterelle wrote: »
    Seems as though Asterelle's block for the redirect no longer works for me D:
    It's working on all my browsers. Are you able to reproduce the error?

    I don't know, it kept happening over and over for me in Chrome, so I used the adblock trick and that seemed to work. I don't know why though :P
    ​​
    dulopa4e1d9.png
    XB1 Thaumaturge PVE CW Build || NW_Legit_Community Moderator || Axios Guild Leader || Neverwinter Trade Forum Moderator
    Check out my foundry, titled "Akro's Gone Wacko", featuring our ex-CM Akromatik!: NW-DL8J7BY5T

    Erza Moonstalker | Lara Moonstalker | Julie Marvell | Erza Moonhunter | Annie Hellangel | Jenn Moonstalker
  • krittycatkrittycat Posts: 4,187 Community Moderator
    asterelle wrote: »
    Seems as though Asterelle's block for the redirect no longer works for me D:
    It's working on all my browsers. Are you able to reproduce the error?

    I don't know, it kept happening over and over for me in Chrome, so I used the adblock trick and that seemed to work. I don't know why though :P


    Did you manually update to the most recent version of the Forum Enhancement? The version just previous to the most recent didn't break the redirect - Asterelle had to push another update to fix the issue.
    ​​
Sign In or Register to comment.