test content
What is the Arc Client?
Install Arc

Melee Attack while firing. Bug?

theboxisredtheboxisred Member Posts: 243 Arc User
edited March 3 in PC Gameplay Bug Reports
While on ground with a toon I haven't played since The Summer Event, she suddenly wants to use the "Jab" melee attack when firing her weapon.

Does anyone have some info as to what is going on?

(Title changed for clarity. - BMR)
Post edited by baddmoonrizin on

Comments

  • ioneonioneon Member Posts: 169 Arc User
    Possibly auto attack on the melee ability? Try right clicking on it.
  • theboxisredtheboxisred Member Posts: 243 Arc User
    ioneon wrote: »
    Possibly auto attack on the melee ability? Try right clicking on it.


    Tried that. Even tried relocating the bind to another key to separate the melee from bolt shot, for example, but once I re-slotted the weapon the two attack modes bind together to the same key. Once I enable the auto fire via the right click it enables both the auto fire on the weapon and the melee. Happens with both rifles and pistols.

    I did find a bug report about this from 2014 or 2015, but there was no response on the forum to that report.

    Thanks for the response and the idea though.

  • where2r1where2r1 Member Posts: 5,900 Arc User
    Did you try using the "Reset to Defaults" button in the "Options" menu...under "Keybinds" tab?

    Make sure you select "Ground" and "RPG Keybinds" or "Shooter". Which ever mode you use.
    Then see if it clears that issue.

    Then, reload your custom keybinds if you are using those. If it the problem comes back...that points to a problem with your custom keybind file.
    "Spend your life doing strange things with weird people." -- UNK

    “Tell me and I forget. Teach me and I remember. Involve me and I learn.” -- Benjamin Franklin
  • theboxisredtheboxisred Member Posts: 243 Arc User
    where2r1 wrote: »
    Did you try using the "Reset to Defaults" button in the "Options" menu...under "Keybinds" tab?

    Make sure you select "Ground" and "RPG Keybinds" or "Shooter". Which ever mode you use.
    Then see if it clears that issue.

    Then, reload your custom keybinds if you are using those. If it the problem comes back...that points to a problem with your custom keybind file.


    Thanks, I'll give this a shot!
  • theboxisredtheboxisred Member Posts: 243 Arc User
    Well, it was good idea, but the issue persists.

    I guess I'll just use that toon for dilithium farming.
  • where2r1where2r1 Member Posts: 5,900 Arc User
    Well, it was good idea, but the issue persists.

    I guess I'll just use that toon for dilithium farming.

    Does this happen with all weapons used by this character???
    Or is it one particular weapon???

    I would remove all weapons and put things back on one by one and see what triggers it.
    Also, check the same with traits messing with your character.
    "Spend your life doing strange things with weird people." -- UNK

    “Tell me and I forget. Teach me and I remember. Involve me and I learn.” -- Benjamin Franklin
  • theboxisredtheboxisred Member Posts: 243 Arc User
    I had considered traits, but yes it seems to happen with all weapons,

    I'll give the traits a whirl, stand by...
  • theboxisredtheboxisred Member Posts: 243 Arc User
    No, the traits don't change anything.

    I'm going to dig through the keybinds again. My brain insists that the issue is there.
  • theboxisredtheboxisred Member Posts: 243 Arc User
    I see the thread was relocated to Bug Reports.

    I wonder if that indicates that it is a known bug, or not.
  • where2r1where2r1 Member Posts: 5,900 Arc User
    I see the thread was relocated to Bug Reports.
    I wonder if that indicates that it is a known bug, or not.

    I think one of the moderators consider it a bug.

    Well, if it is not gear, and keybinds are set to default and it is still doing it......

    Last thing I can come up with is: Force Verify.

    "Spend your life doing strange things with weird people." -- UNK

    “Tell me and I forget. Teach me and I remember. Involve me and I learn.” -- Benjamin Franklin
  • ioneonioneon Member Posts: 169 Arc User
    ioneon wrote: »
    Possibly auto attack on the melee ability? Try right clicking on it.
    Thanks for the response and the idea though.

    Was worth a shot. Seems to me like I had this same thing happen to me years ago. I apologize if this sounds condescending, but you're absolutely sure the melee attack is not set to auto attack? The icon is not highlighted green? I just bug tested this for a half hour or so to try and reproduce it somehow. Setting the melee attack (rifle butt in this case) to auto attack was the only way I could reproduce it.

  • theboxisredtheboxisred Member Posts: 243 Arc User
    [/quote]

    Was worth a shot. Seems to me like I had this same thing happen to me years ago. I apologize if this sounds condescending, but you're absolutely sure the melee attack is not set to auto attack? The icon is not highlighted green? I just bug tested this for a half hour or so to try and reproduce it somehow. Setting the melee attack (rifle butt in this case) to auto attack was the only way I could reproduce it.

    [/quote]

    That's not condescending at all as I am capable of Nth level absentmindedness.

    The melee attack and the fire weapon are defaulting to the same bind, so that when I set the weapon to auto fire the melee is set to auto fire as well. For example, equip the weapon and the melee attack becomes the weapon attack. The weapon works normally if auto fire is not enabled. Once I right click to enable auto fire on the weapon the melee gets set to auto fire as well and the weapon will fire once, then the melee, then the weapon again, then the melee, then once the enemy is down, the melee continues to trigger.

    Tried everything above including slotting the melee strike (Jab, to be specific) to a different bind before equipping a weapon, but the weapon overrides melee no matter where slotted. I've even tried changing clothes in the tailor because this first occurred after a visit to the tailor. Nope, no luck there.

    This seems to be happening on the just one toon which is why I think a setting got burped out of place somehow.


  • theboxisredtheboxisred Member Posts: 243 Arc User
    ruinthefun wrote: »
    This is a feature, sometimes the game just forgets that some characters have a gun equipped and treats the slot as empty. To fix, press Z twice to switch from and back to the gun.

    Negative. Didn't take.
  • where2r1where2r1 Member Posts: 5,900 Arc User
    Well... What I would do is: remove gear from this character...then do a Force Verify.

    Hopefully, the program resets the trays in the proper default mode without being encumbered with weapons on board.

    Otherwise, I think it is customer service... I have had good luck with the online chat folks.
    But you may want to avoid lunch hour. It is 10:30am in California, right now.

    @chrian#9670
    "Spend your life doing strange things with weird people." -- UNK

    “Tell me and I forget. Teach me and I remember. Involve me and I learn.” -- Benjamin Franklin
  • theboxisredtheboxisred Member Posts: 243 Arc User
    FIXED IT!

    I found that "Palm Strike," though not equipped, was set to auto fire and was being triggered along with the slotted weapon.

    To resolve, I slotted palm strike elsewhere and disabled the auto fire, then pulled it out of the slot once more.

    Thanks everyone for the ideas!
  • ioneonioneon Member Posts: 169 Arc User
    FIXED IT!

    I found that "Palm Strike," though not equipped, was set to auto fire and was being triggered along with the slotted weapon.

    To resolve, I slotted palm strike elsewhere and disabled the auto fire, then pulled it out of the slot once more.

    Thanks everyone for the ideas!

    Awesome, glad you fixed it!
  • theboxisredtheboxisred Member Posts: 243 Arc User
    Thanks!

    I just hope this solution makes it to the next player who encounters the issue.
Sign In or Register to comment.