test content
What is the Arc Client?
Install Arc

M'Chla Bird of Prey shooting from wingtips? This is wrong

antiquesroadshowantiquesroadshow Member Posts: 193 Arc User
I just bought the new Dis Bird of Prey ship. When I watched the livestream a few days ago, I was so excited. Everything was looking right in place. Today when I bought it. To my horror. I see it fires from the wingtips where there are no cannons! On the livestream it did not do that. This used to be a problem back in the day when ships used to fire from the nacelles. It looked so bad and cheap. But they fixed it! Now it seems to have crept back in one of my favorite ships! I know it wasn't like this a few days ago. And it must have got past quality control. I am so disappointed. It makes the ship look so, so cheap. Can they fix this?? Please, oh please Cryptic, fix the firing from wing tips mistake! I thought those days were gone for good! It looks so bad.

Comments

  • kellmg96#5851 kellmg96 Member Posts: 372 Arc User
    if it is a mistake, maybe this should go in the bug forum.
    sE8rUC0.jpg
    T6 Cooperative Tactical Dreadnought ~ Mirror Universe Borg Queen Leeta
  • where2r1where2r1 Member Posts: 5,866 Arc User
    This was mentioned on the patch notes for today:
    Engine trails of the M'Chla Bird of Prey have been moved from the wings to the central spine so that engine visual attachments are placed more appropriately.

    https://www.arcgames.com/en/games/star-trek-online/news/detail/11094093

    So, the Engine trails were moved off the wings? Now, the weapons are on the wings???

    I am not clear what was before and what was after this morning's patch. Even though I bought my M'Chla...I have not switched any characters into it. As I am using all my in game time farming Omegas....must feed my hoarding tendencies.
    "Spend your life doing strange things with weird people." -- UNK

    “Tell me and I forget. Teach me and I remember. Involve me and I learn.” -- Benjamin Franklin
  • antiquesroadshowantiquesroadshow Member Posts: 193 Arc User
    edited February 17
    :UPDATE TO POST:

    I have just found out that it is the weapon type that caused the problem. The ship comes default Dual Cannons. If you switch them out for Dual Heavy Cannons, the glitch occurs. So if you stay with updating to only Dual Cannons you will not have this issue. But if you use any other weapon type, you could glitch up. This is an issue that I have seen before. It also happens if you use Dual Beam Banks on the Qugh Miracle Worker Battlecruiser. They don't fire from the Gun Turret. Fed ships are also affected. (Trolling comments removed. - BMR)
    Post edited by baddmoonrizin on
Sign In or Register to comment.