test content
What is the Arc Client?
Install Arc

Do we really have to redownload everything?

iamnotnormaliamnotnormal Posts: 66 Arc User
edited October 2018 in Support Desk
old location is not recognized by arc client..
so what is the fix for this ty...
i submitted a ticket also just to speed things up.
PLAY BUTTON is changed to INSTALL
«1

Comments

  • download everything.. hahaha only way right now.. i wont waste my time doing batch file for them to reap the benefits of my hardwork... from the looks of my tickets... they not gonna fix this and let us redownload every thing...
  • tara#6530 tara Posts: 1 Arc User
    also got that problem . but using launcher.exe from pwi folder is working for me
  • kakadiyaskakadiyas Posts: 6 Arc User
    tara wrote: »
    also got that problem . but using launcher.exe from pwi folder is working for me

    launcher.exe will promt to download arc again , so it's not working ...

    up untill now it was fine , today just few mins ago i also got the problem n now game is completely gone from library .
    Like seriously wth is this ? feels like more ppl will get this bug sooner or later.
    25tavxl.jpg

  • vendi#0954 vendi Posts: 9 Arc User
    and yeah i got the same problem now :(
  • baseaddressbaseaddress Posts: 193 Arc User
    I got this problem yesterday.
  • heedless#6864 heedless Posts: 1 Arc User
    Got this problem just right now. 16GB download again... no way.
  • congratulations you got punk'ed.. download everything enjoy
  • katjenkureakatjenkurea Posts: 12 Arc User
    same problem i got yet suddenly i can only "install"

    are there still no solutions? i tried alot including arc repair

    the game is fully installed still show all 19 gb but the instalation ask over 30 gb

    something there is not right or did they finaly improve the graphic and engine?

    if so then we all had get a big update i think not a forced download of over 15 gb more
  • quinniequinnie Posts: 46 Arc User
    got the same **** now... and its asking indeed for 31,885 gb... like wtf pwi its total bs...
    Etherblade
    HaarKoning
    MrLens
    MrGiggleShyts
  • allleyallley Posts: 8 Arc User
    anything new on a fix for this problem?
    should we wait to see if they fix this issue or just give up and download all over again?
    compensation: will we get anything ( worthwhile that is)
  • indeterminateindeterminate Posts: 7 Arc User
    Redownloading is merely inconvenient for anyone with unlimited data and a fast connection.

    It's a major problem for anyone with a data limit or slow net.

    Given that it's likely a very small fix, it would be nice for pwe to actually do something about it for once.
  • vacekiravacekira Posts: 8 Arc User
    edited November 2018
    Hello,

    I had problem today.. ARC showing install button.

    Here is what i did using "regedit".

    dz2qf.jpg

    Now everything works as before just fine.

    See you in game :)

    Edit 1:

    On screenshot above, you can see red text that says "Find this." But as people have problems finding those keys, screenshot below provides a little help on that.

    hv7w42.jpg

    Edit 2:

    Hello, if above two screenshots aren't working for you, try this as it should be most universal solution:

    f9p2zk.jpg
    Post edited by vacekira on
    Tideswell
  • sjampiesjampie Posts: 373 Arc User
    edited November 2018
    Yup vacekira, it works IF people have the registry like you showed in the screenshot. In my case Arc and Core not showing up on this location but - lucky me - I don't have any problem.s Also this topic wasn't written in Support Desk so I didn't had the feeling of writing something lol.

    The problem can also happen with other games. Arc sucks sometimes but I expect this will be solved by PWE later on.

    Think in addition of your reply people can use this:
    1. start Regedit
    2. press [CTRL][F]
    3. search for CLIENT_PATH
    4. change the value to the location of elementclient.exe
    5. do the same for the other folders.

    vacekira, thank you for your response. ;)


    edit: not sure if people have this but in Arc menu Library, if you click + is the menu going to Games? In the past people could locate their game but I think PWE want to let us use Arc only (so people think the solution is to re-download the game). Would be very bad if PWE solve problems in this way.
  • indeterminateindeterminate Posts: 7 Arc User
    Sadly this fix doesn't work for me; I don't have an appinstallconfig file.

    My game and arc folders are separate, presumably as I played pwi long before arc, and only added arc when it was forced upon us in order to play.
  • heero200heero200 Helper Extraordinary Posts: 3,478 Community Moderator
    Sadly this fix doesn't work for me; I don't have an appinstallconfig file.

    My game and arc folders are separate, presumably as I played pwi long before arc, and only added arc when it was forced upon us in order to play.

    yer this is what im putting this down to as well.

    Thanks.​​
    - Support Ticket - ARC Forums - PW Wiki - PWI Arc Codes - Time Changes EU / US

    Support Email: cust[email protected]
  • elcocotelcocot Posts: 17 Arc User
    i was wondering why is archosaur so empty. this will kill next wave of players. and the player base is already so decimated...
  • sjampiesjampie Posts: 373 Arc User
    elcocot wrote: »
    i was wondering why is archosaur so empty. this will kill next wave of players. and the player base is already so decimated...

    Think you'll need to start a new forum post and ask this question. I'm sure people who left the game will not reply unless they're addicted to the forum.

  • heero200heero200 Helper Extraordinary Posts: 3,478 Community Moderator
    sjampie wrote: »
    elcocot wrote: »
    i was wondering why is archosaur so empty. this will kill next wave of players. and the player base is already so decimated...

    Think you'll need to start a new forum post and ask this question. I'm sure people who left the game will not reply unless they're addicted to the forum.

    I think maint had just been completed
    I'm sure it's back to normal now.

    Thanks.
    - Support Ticket - ARC Forums - PW Wiki - PWI Arc Codes - Time Changes EU / US

    Support Email: [email protected]
  • sjampiesjampie Posts: 373 Arc User
    Hi heero200,

    Even I noticed less players 'active' (if we can call catshops less active). Also missing a lot of people. This could mean that they're busy with more important stuff in real life or just a real 'afk' because of idk... Halloween. Today I only miss the 40+ Jolly Old Jones bots near Plume but I presume they will be back. Haven't checked all servers.
  • johndoe069johndoe069 Posts: 94 Arc User

    I had this same issue today and almost game up playing cos PWI....

    But thanks to this post and this screenshot in particular i could get the game working again without re downloading!!
    My reg didnt have the 3en reg key in the Core dir (on the left dir tree) so i just created one myself and added the value to it as shown in the screenshot (right side values) ( making sure to add the right install directory paths for each value) and it works fine now.

    So tytytytyty vacekira!

    vacekira wrote: »
    Hello,


    Here is what i did using "regedit".

    dz2qf.jpg

    Now everything works as before just fine.


    key2_zps6ck5dj7q.png
  • psybuffer1psybuffer1 Posts: 1 Arc User
    Sadly this fix doesn't work for me; I don't have an appinstallconfig file.

    My game and arc folders are separate, presumably as I played pwi long before arc, and only added arc when it was forced upon us in order to play.

    Happened to me today for the first time also have separate folders for Arc and PWI and don't have appinstallconfig file. So am stuck downloading again. Didn't have a problem until after this recent maintenance when I tried logging in this morning.
  • indeterminateindeterminate Posts: 7 Arc User
    Well, my desktop is affected too now, so no more pwi for me until further notice.

    Congratulations on another epic piece of trashware, and good luck trying to get people to charge if they can't access the game
  • sjampiesjampie Posts: 373 Arc User
    psybuffer1 wrote: »
    Sadly this fix doesn't work for me; I don't have an appinstallconfig file.

    My game and arc folders are separate, presumably as I played pwi long before arc, and only added arc when it was forced upon us in order to play.

    Happened to me today for the first time also have separate folders for Arc and PWI and don't have appinstallconfig file. So am stuck downloading again. Didn't have a problem until after this recent maintenance when I tried logging in this morning.

    The appinstallconfig.xml file only contains the following text:

    <?xml version="1.0" encoding="utf-8" standalone="yes" ?>
    <installconfig appid="3" appname="PWI">
    <registry language="EN" installed="0">
    <coreitems>
    <item itemname="INSTALL_PATH" itemtype="string" rootpath="HKEY_LOCAL_MACHINE" path="Software\Perfect World Entertainment\Core\3en" value="%INSTALLDIR%\" />
    <item itemname="PATCHER_PATH" itemtype="string" rootpath="HKEY_LOCAL_MACHINE" path="Software\Perfect World Entertainment\Core\3en" value="%INSTALLDIR%\patcher\patcher.exe" />
    <item itemname="LAUNCHER_PATH" itemtype="string" rootpath="HKEY_LOCAL_MACHINE" path="Software\Perfect World Entertainment\Core\3en" value="%INSTALLDIR%\launcher\launcher.exe" />
    <item itemname="CLIENT_PATH" itemtype="string" rootpath="HKEY_LOCAL_MACHINE" path="Software\Perfect World Entertainment\Core\3en" value="%INSTALLDIR%\element\elementclient.exe" />
    </coreitems>
    <appitems>
    <item itemname="" itemtype="string" rootpath="HKEY_CLASSES_ROOT" path=".cup" value="CPWUpdatePack" />
    <item itemname="" itemtype="string" rootpath="HKEY_CLASSES_ROOT" path="CPWUpdatePack" value="Perfect World new patch" />
    <item itemname="" itemtype="string" rootpath="HKEY_CLASSES_ROOT" path="CPWUpdatePack\DefaultIcon" value="%INSTALLDIR%\patcher\patcher.exe,0" />
    <item itemname="" itemtype="string" rootpath="HKEY_CLASSES_ROOT" path="CPWUpdatePack\shell\open\command" value="%INSTALLDIR%\patcher\patcher.exe /localupdate:%1" />
    </appitems>
    </registry>
    <dependency />
    </installconfig>

    So you can make this file yourself using Notepad and save it as a .xml file instead of a .txt file. Just copy/paste the text above.

  • indeterminateindeterminate Posts: 7 Arc User
    edited November 2018
    It might be usable, with some edits, I'll take a closer look when I get home from work


    EDIT: Ok, here's an update.

    I reconfigured my folders to the same nest structure as a new install would be.

    I discovered arc/pwi update/the Grinch had deleted all pwi keys from HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node

    Rewrote pwi reg keys to reflect my current file tree, and added Sjampe's appinstallconfig to pwi folder (had to move it in, rather than write and save directly in it, silly admin structure).

    Now back in game, will have to see how long it lasts... also need to repeat the fix on my desktop now


    EDIT2: Thankyou to Sjampe and vacekira for their invaluable input <3
    Post edited by indeterminate on
  • vacekiravacekira Posts: 8 Arc User
    edited November 2018
    Hello,

    I have posted some screenshots for install/play button fix but if u find them confusing, here is how to fix your game easy:

    Open Notepad: copy and paste code (which is posted on bottom of this post), then click "File" in notepad, and click "Save as" and type pwi.reg as file name, and below where it says "Save as type" click and select "All files" then click "Save".
    After saving file, you just need to run it once. (by double clicking on it).

    NOTE, my:

    Arc is in C:\Program Files (x86)\Arc ,
    PWI game is in F:\Perfect World\PWI_en

    So you might need to change paths in code to match your Arc and PWI game installation directory.

    Code:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Perfect World Entertainment]
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Perfect World Entertainment\Arc]
    "client"="C:\\Program Files (x86)\\Arc\\Arc.exe"
    "patcher"="C:\\Program Files (x86)\\Arc\\ArcUpdate.exe"
    "launcher"="C:\\Program Files (x86)\\Arc\\ArcLauncher.exe"
    "SystemSurveryCollection"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Perfect World Entertainment\Arc\1.0.0.9668]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Perfect World Entertainment\Core]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Perfect World Entertainment\Core\3en]
    "INSTALL_PATH"="F:\\Perfect World\\PWI_en\\"
    "installed"=dword:00000001
    "PATCHER_PATH"="F:\\Perfect World\\PWI_en\\patcher\\patcher.exe"
    "LAUNCHER_PATH"="F:\\Perfect World\\PWI_en\\launcher\\launcher.exe"
    "CLIENT_PATH"="F:\\Perfect World\\PWI_en\\element\\elementclient.exe"
    "APP_ABBR"="pwi"
    Post edited by vacekira on
    Tideswell
  • i cant find Perfect World Entertainment string at registry..any1 can tell me how to fox it?
  • sjampiesjampie Posts: 373 Arc User
    i cant find Perfect World Entertainment string at registry..any1 can tell me how to fox it?

    You don't have to search for it, just let the Registry Editor search for you. If you do it yourself then you can search the location mentioned by vacekira, above your comment. The text should give you enough info about how to fix it. Then there could also be another location: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Perfect World Entertainment. If you don't want to do any of this, re-download the game is the only option.
  • i've found at registry its in Wow6432Node and already try what vacekira did but its still doesnt work
  • sjampiesjampie Posts: 373 Arc User
    i've found at registry its in Wow6432Node and already try what vacekira did but its still doesnt work

    So you still have the Install button? Would be easier just to click on it but if you still want to change things manually you should give the exact location of the game otherwise the game will never work.
«1
Sign In or Register to comment.