test content
What is the Arc Client?
Install Arc

weird launcher problem

kuokweikuokwei Posts: 5
can't even update and play, it doesn't have the play button or update


  • drakenfyredrakenfyre Posts: 6,879 Community Moderator

    Is your ARC system up to date? If the Verify option is lit up did you try running that?

    Swordsman Moderator, Forsaken World Moderator, Jade Dynasty Moderator
    I do not have the staff on speed dial
    Insanity Runs Downhill
  • kuokweikuokwei Posts: 5
    edited March 2015
    is the current arc version v1.1.0.12738 cos i check the version it say it is up to date
    i can start this game smoothly from KOG games but here i got problem playing this game but other games like jade dynasty, battle of immortal, war of immortal don't have this problem
  • drakenfyredrakenfyre Posts: 6,879 Community Moderator
    I'll see if I can get someone to take a look at this
    Swordsman Moderator, Forsaken World Moderator, Jade Dynasty Moderator
    I do not have the staff on speed dial
    Insanity Runs Downhill
  • strumslingerstrumslinger Posts: 551 Arc User
    Hey kuokwei,
    Can you submit a ticket to KOG games telling them everything you told us here? I think they'd be able to help you out the most. Make sure to mention you're trying to launch this game from Arc. http://support.elswordonline.com/

    Call me Andy (or Strum, or Spider-Man)!
    Follow Neverwinter on Twitter: NeverwinterGame 
    Like Neverwinter on Facebook: Neverwinter
    Follow me on Twitter: StrumSlinger

  • kuokweikuokwei Posts: 5
    k yesterday i tried to reinstall it it can update but it only has the grey screen appeared and it just close within few seconds. since it is from KOG gmaes i should play from KOG games cos i play their one no problem thanks for ur suggestion and yesterday morining i had create a KOG games account and play elsword (KOG games official client) it works

    is ur elsword online original 

    i doesn't mean that i wont use arc again since i got few games there
  • xdrockloxdrocklo Posts: 2
    Can anyone help me? Every time I Try to start the gmae it gives me this message: "Unable to Download The File Version" Pls help me 
  • captravensoulcaptravensoul Posts: 10 Arc User
    im from belgium why ismy region not alowed to play this game wth al other games i can play
  • oscar1225oscar1225 Posts: 6 Arc User
    My game was just installed and updated but says no response from the server, what shall i do?
  • hazelluna397hazelluna397 Posts: 3 Arc User
    edited July 2015
    Hi, i downloaded Elsword but whenever i click the Play button it says to launch Elsword from Arc which i did but it never worked. Please help. I did manually add Elsword to arc but still not working.
  • fenikkusuikkifenikkusuikki Posts: 2 New User
    I just installed Elsword, but when I click play button it says "not response from server".... What's the problem? I'm from Argentina.
  • Just installed the game but im only reaching up to the point that gameguard launches and thats it. Nothing after.
Sign In or Register to comment.