test content
What is the Arc Client?
Install Arc

Elsword Issues Compilation

13»

Comments

  • entrie19930107entrie19930107 Posts: 1 Arc User
    edited July 2015
    Hey guys i figuired out the region blocking problem:
    I downloaded "Hotspot shield" and I just started downloading the game without any problems
  • ncweber00ncweber00 Posts: 6 Arc User
    I can launch the updater for Elsword, but after it finishes patching, the launcher closes and a window appears saying that MailMIME.dll cannot be found, even though that file is in place both in the Elsword\data folder and the Windows\system32 folder.
  • captravensoulcaptravensoul Posts: 10 Arc User
    tenkorex wrote: »
    Have game listed with Install option but returns with "This game is not available in your region"? (UK Player)

    same here im from belgium and not alowed to play from my region other games on arc i can play from here why this game not

  • velkrosvelkros Posts: 29 Arc User
    edited July 2015
    I turn off the tooltips just to have them show again. Unless, this is a new feature Elsword has that I didn't experience a couple of years ago.
  • aronia78aronia78 Posts: 2 Arc User
    menduca wrote: »
    Maybe this help

    Yeah i get this same problem, and i heard this game is awesome.
    Plz check it out guys :)
  • fenikkusuikkifenikkusuikki Posts: 2 New User
    I just installed Elsword, but when I click play button is shows me the grey window and the "no response from server" message, and it closes... What can I do to play Elsword? I'm from Argentina
  • jeddex01jeddex01 Posts: 3 Arc User
    I still can't play this game. i already start uninstall and reinstalled using arc. But after gameguard launches it only shows gray window then exits. I can't even see what's the error message.
  • flechanegroflechanegro Posts: 1 Arc User
    what happened with this game cant play :/ all time say me server error
  • loging in to the internet explorer where you go first to...arc launcher then play game then internet explorer sign in arc account pops up and when i log in with my arc account it suddenly blackss and sayss "True failed'
  • wolfeofhopewolfeofhope Posts: 1 Arc User
    Every time I try to play Elsword after loading a grey box appears for a few seconds and then an alert pops up saying error. I have Windows 10 if anyone could help me.
  • taurenshank88taurenshank88 Posts: 1 New User
    Tried launching Elsword earlier. Just installed it. It did the whole "Downloading Files" thing for like an hour.
    Once it hit 100 % I waited for, what I was hoping for, the "Play" or "Start" button to appear.... *Window closed*

    ...??.. ok....?

    Launched it again. waited for it to Verify that it was the most current Version. that finished....waited..... waited.... *Window Closed*... whaaaaaa.

    Thought i would be smart and launch it again with my task manager open hoping to figure out what all it was doing whilst loading... *Elsword closed* again. Just disappeared from Task manager option.

    Is this a game crash from launch or what??

    Anything?
  • kantutzkillkantutzkill Posts: 1 New User
    > @crowroth said:
    > Whenever I launch the game, it'll load up and then the page says its not responding. I relaunched the game about 10 times and I ran arc as an administrator. Nothing worked. Please help. I'd really like to play the game soon (:
  • valcrist24valcrist24 Posts: 1 Arc User
    The launcher goes straight to Internet Explore. What is up with that? No true or false thing, just goes to Internet Explorer with it saying Cannot Connect to Internet.....
  • This has likely been reported a lot recently, but this game, Elsword, takes a MINIMUM of 5 minutes to load to a playable state. It often takes more time than that. My sytem is not the issue, it has MORE than adequate specs to run this game. For this reason, I usually lose patience and play something else. Hell, Fallout 4 beats it by a country mile in the load race, mods and all.
  • msteelmsteel Posts: 1 Arc User
    Hello
    Any issue with the game?
    I have not been able to get the launcher to "launch" for the last few days. When I click "play" on Arc nothing happens
  • hatchetknightshatchetknights Posts: 1 Arc User
    menduca said:

    Maybe this help

    that's exactly the same error i'm getting...
    Install: perfect
    Patching: perfect
    Loading: took time but still good
    Connecting to server: does it exist? -_-

    Is there a solution for this?

    Also, my computer meets the requirements, and it's a windows 10
  • yahmenyahmen Posts: 1 Arc User
    the still not working...
    i just downloaded it today and patches it but everytime i launches the game it just automatically close its windows
  • hazu04#6001 hazu04 Posts: 1 New User
    > @yahmen said:
    > the still not working...
    > i just downloaded it today and patches it but everytime i launches the game it just automatically close its windows

    I have the same problem. I even reinstalled the game but it still automatically close.
  • xkazatelxxkazatelx Posts: 1 Arc User
    elsword is stupid name btw and of course this game don't work. I'm in bad region. lol. So take this crap out from arc quests!
  • norelis#1416 norelis Posts: 5 New User
    Reduction of lag

    Hello,

    This post is dedicated for those who suffer from lag and high ping, NoPing is software that greatly optimizes your gameplay.

    With unique technology, NoPing Tunnel traces the best route to the server of your favorite online game.

    Gaining up to 50% improvement depending on your internet!

    Test for 3 days for free, if you register at the link below:

    nopi.ng/forum23

    Watch the video below with and without NoPing!
  • velyna#6287 velyna Posts: 1 New User
    edited February 2018
    sound isn't playing for me
  • Got an issue, Stuck on launcher it says "Downloading files from patch path" yet I've been on the launcher for about 1hr and 30mins and nothing is happening! Yet i was playing it yesterday?
  • Hello everyone, I will continue the topic! Guy, help advice. I bought new headphones on the type of these. All music is heard normally, movies too. But in the Arch there is a bug with sound, like an echo. Put the old headphones on the same. What is the problem in the Drivers or maybe in the game. If someone started and solved the problem, please write down!
    Thanks in advance and successful games
13»
Sign In or Register to comment.