test content
What is the Arc Client?
Install Arc

So does this game even work?

heaythemheaythem Posts: 1 Arc User
Saw a post about the same issue that I am having but never really gotten a real answer on how to solve it. I first noticed APB Reloaded about two weeks ago. I watched the trailer for it, checked out some screenshots and read what the game was all about. Thought I might try it out see I'd enjoy it. So I go to download it on Arc. With the download complete I click play. Another launcher pops up to download some updates for it. This launcher looked somewhat similar to the launchers of two other games I used to play (not really relevent). I stepped aside for a bit to wait for all the downloading to finish. When I came back the game was ready to play. So I clicked play. Nothing happens. I think alright my computer has done this before when I download new games. I went to eat dinner leaving my computer as it was so it would load up. I come back. Nothing. I check my computer. It wasn't frozen and the only things that were open were Arc and Chrome. I decide to run it again. Click play. Normally when i go to run a game twice my computer will have an error pop saying that that program is already running and if i would like to wait or close the first one that was started. That didn't even pop up. So i wait about 10 minutes to give the game time to load up. Nope. I restart Arc and try again. Click play, get to the other launcher and click play there. Nothing is happening. I take to the forums see if there were other people experiencing what I was and if there was an answer to this. Yes there were some people with the same problem but no answers. I saw a post about a loading screen and freezes, a crash after character creation, and the Arc browers preventing gameplay. Nobody got answers. There was another post about a problem similar to mine except they had an error code. I don't even get that. If I did I would at least know what was wrong. Now that post did get an answer but nothing really helpful. So I did some searching. This game wasn't always availble on Arc and found a download for it on the G1 website. I uninstall it from Arc and try the other download that I found. Nothing. Again. It downloads. I click play. Doesn't start. So I uninstalled it form my computer again until today where I have tried it for the second time on Arc. Still doesn't work. Check the forums and still no answers. I would really like some help figuring this out but seeing as how there hasn't been a game update since Febuary (of this year I'm assuming) I don't see it as very likely. And if somebody does know something is it my computer or is it something on the developer's side thats not working? But don't ask me if I'm getting an error code because I'm NOT. And that "the game doesn't work isn't much to go on." It's not but yet what other way is there if there isn't an error code poping up. I want to give this game a shot and see what I think of it but it doesn't even start. And if it ends not being that the game isn't even running anymore then why not just remove it instead of getting people's hopes up for something that not working. You know.
Sign In or Register to comment.