test content
What is the Arc Client?
Install Arc

PWE Forums Enhancement Extension - Discussion and Requests

1910111214

Comments

  • sylenthundersylenthunder Posts: 256 Community Moderator
    chaelk wrote: »
    my entire enhance has vanished. where's the download link again. greasemonkey is still connected.
    please bung it in my avatar area. .
    First post man. Look at the first post.​​
  • ediraedira Posts: 32 Arc User
    The discussion manager moved from the right side of the screen to the center. I've just now noticed this... is this a recent change?​​
    Forsaken World - Server: Dyos - Kindred Fire Mage
  • sylenthundersylenthunder Posts: 256 Community Moderator
    Urgh. I took a nap and wake up to see I'm stuck on it redirecting to Arcgames.com again and it's breaking all my #latest effect on threads. I get the "Do you want to leave this page" popup from the plugin, but it's still redirecting.​​
  • asterelleasterelle Posts: 368 Arc User
    edited November 2015
    Yeah they changed something so now it keeps wanting to redirect. Why do they have to be so insistent?

    Hmm.. where is this new redirect anyway? It's not in embed_local.js, I'm still getting it when I block that js.
    ​​
    Post edited by asterelle on
  • gulberatgulberat Posts: 400 Arc User
    For the first time it seems to be defeating my AdBlock. I hope someone finds a new way to stop it, fast.

    Christian Gaming Community Fleets--Faith, Fun, and Fellowship! See the website and PM for more. :-)
    Proudly F2P.  Signature image by gulberat. Avatar image by balsavor.deviantart.com.
  • sylenthundersylenthunder Posts: 256 Community Moderator
    Maybe the script is embedded on the page? I'm kinda a noob at js, but this looks interesting....
    <script type="text/javascript">gdn=window.gdn||{};gdn.meta={"AnalyticsTask":"tick","RemoteUrl":"http:\/\/www.arcgames.com\/en\/forums","ForceEmbedForum":"0","ForceEmbedDashboard":"0","Path":"discussions","InDashboard":"0","TagHint":"Start to type...","TagSearching":"Searching...","editorVersion":"1.7.5","editorPluginAssets":"\/pwi\/plugins\/editor","wysiwygHelpText":"You are using <a href=\"https:\/\/en.wikipedia.org\/wiki\/WYSIWYG\" target=\"_new\">WYSIWYG<\/a> in your post.","bbcodeHelpText":"You can use <a href=\"http:\/\/en.wikipedia.org\/wiki\/BBCode\" target=\"_new\">BBCode<\/a> in your post.","htmlHelpText":"You can use <a href=\"http:\/\/htmlguide.drgrog.com\/cheatsheet.php\" target=\"_new\">Simple HTML<\/a> in your post.","markdownHelpText":"You can use <a href=\"http:\/\/en.wikipedia.org\/wiki\/Markdown\" target=\"_new\">Markdown<\/a> in your post.","textHelpText":"You are using plain text in your post.","editorWysiwygCSS":"\/pwi\/plugins\/editor\/design\/wysiwyg.css","maxUploadSize":52428800,"editorFileInputName":"editorupload","allowedFileExtensions":"[\"txt\",\"jpg\",\"jpeg\",\"gif\",\"png\",\"bmp\",\"tiff\",\"ico\",\"zip\",\"gz\",\"tar.gz\",\"tgz\",\"psd\",\"ai\",\"fla\",\"pdf\",\"doc\",\"xls\",\"ppt\",\"docx\",\"xlsx\",\"log\",\"rar\",\"7z\"]","maxFileUploads":"20","canUpload":false,"TransportError":"A fatal error occurred while processing the request.<br \/>The server returned the following response: %s","TransientKey":"5QLCE48HT46K","WebRoot":"http:\/\/forum.arcgames.com\/pwi","UrlFormat":"\/pwi\/{Path}","Args":"remote=http%3A%2F%2Fwww.arcgames.com%2Fen%2Fforums%2Fpwi&locale=&sso=eyJ1bmlxdWVpZCI6IjI1MjI5NzMiLCJuYW1lIjoic3lsZW50aHVuZGVyIiwiZW1haWwiOiJzeWxlbnRodW5kZXJAYXR0Lm5ldCIsInBob3RvdXJsIjoiaHR0cDpcL1wvaW1hZ2VzLWNkbi5wZXJmZWN0d29ybGQuY29tXC9hcmNcL2YyXC83MFwvZjI3MDAxYTM0OTljNGNlMTE3YzI1YzEyMTg1ZWIzODUxNDQwNzA2MDg4LnBuZyIsInJvbGVzIjoiTWVtYmVyLFBXSSBNb2RlcmF0b3IiLCJjbGllbnRfaWQiOiIxNDQzOTY4OTgxIn0%3D+9f144dd3174b7671c808358c8868f6953ce27d58+1447815987+hmacsha1","ResolvedPath":"vanilla\/discussions\/index","ResolvedArgs":"{\"Page\":false}","SignedIn":2,"SetHourOffset":-5,"ConfirmHeading":"Confirm","ConfirmText":"Are you sure you want to do that?","Okay":"Okay","Cancel":"Cancel","Search":"Search"};</script>
    
    It's in the frame source.
    "ForceEmbedForum, and "ForceEmbedDashboard" are what caught my eye.​​
  • asterelleasterelle Posts: 368 Arc User
    edited November 2015
    That was me circumventing the old redirect from "embed_local.js". I found the new redirect in "custom.js".


    function clearBackground() {
    var framed = (window.location != window.parent.location) ? true : false;
    if(framed) {
    $('body').css('background', "transparent");
    } else {
    // if not framed, kick them to arcgames
    var loc = window.location.pathname;
    var s = loc.split('/');
    s[1] = s[1] + "?byNode=true#";
    var uri = s.join('/');
    var domain = "http://www.arcgames.com";
    var url = domain + '/en/forums' + uri;
    window.location.href = url;
    }
    }



    That window.location.href is the redirect occurs after it detects the page is not embedded.

    How am I supposed to stop that?... hmm

    EDIT: Filtering http://forum.arcgames.com/arc/themes/Arc/js/custom.js in adblock does work but I'm looking for a clean solution to block that one function
    [/color]​​
  • sylenthundersylenthunder Posts: 256 Community Moderator
    asterelle wrote: »
    That was me circumventing the old redirect from "embed_local.js". I found the new redirect in "custom.js".
    That's what I thought at first, but was still there after I had turned off the enhancement. Chrome likes to hang onto stuff too long I guess.​​
  • sylenthundersylenthunder Posts: 256 Community Moderator
    Crap, the adblock filter isn't working for me. Tried both regular ABP and the Beta.​​
  • gulberatgulberat Posts: 400 Arc User
    edited November 2015
    @asterelle, that only worked for me on this part of the forum. No luck over on STO. Going to see if I can figure out how to customize it to work there too.

    EDIT: It took me a VERY quick trigger finger to find it, but it looks like the redirect has a different URL for each forum. The redirect for STO is http://forum.arcgames.com/startrekonline/themes/Arc/js/custom.js

    Christian Gaming Community Fleets--Faith, Fun, and Fellowship! See the website and PM for more. :-)
    Proudly F2P.  Signature image by gulberat. Avatar image by balsavor.deviantart.com.
  • khamseenairkhamseenair Posts: 345 Arc User
    edited November 2015
    Why oh why do they feel this need to force people onto the embedded forum? The embedded forum is broken and hideous. :(
    gulberat wrote: »
    EDIT: It took me a VERY quick trigger finger to find it, but it looks like the redirect has a different URL for each forum. The redirect for STO is http://forum.arcgames.com/startrekonline/themes/Arc/js/custom.js


    Added to my adblock for now until Asterelle can come up with a cleaner solution. Thanks :)
    ​​
    <center>Ciaran%20Sig.jpg
    Join date is wrong, I've actually been around since STO Beta.
    True alters don't have a "main". Account wide unlocks for all unique event rewards!!
    Check my GitHub for details on STO forum themes: https://github.com/khamseen/PWEVan
    Get the Forums Enhancement Extension!</center>
  • asterelleasterelle Posts: 368 Arc User
    edited November 2015
    Adblock might be the only solution...

    I don't know if browsers can guarantee that they will actually run my code into the window between when that function is declared in that .js and when the function is called inline at the top of the page. So far I've tried injecting a javascript node between the two, deleting the custom.js javascript node, various methods to predeclare that function name as const, not much luck yet.

    This type of thing is pretty annoying tiger-9.gif. There isn't much help online for this type of issue either so I'm just trying whatever. It's in the global namespace at least so you'd think something would work.
    ​​
  • sylenthundersylenthunder Posts: 256 Community Moderator
    edited November 2015
    It's working on this forum finally, but I still cannot get it to work on the PWI forum. EDIT: Would just figure. I post this and it miraculously starts to work.

    Also, why the hell does the embed completely break their own #latest function? With no embed, it works perfectly. With the embed, I usually end up at the top of the page, or sometimes randomly in the middle of it.​​
  • nrglgnrglg Posts: 347 Arc User
    I've never seen a place this hell-bent on redirecting users to a slower and more resource consuming iframe version of their forums. I just don't understand the obsession.

    For anyone who wants, this should block the new custom.js and embed.js redirection for all of the sites and anything within it.
    *forum.arcgames.com/*/js/embed.js
    *forum.arcgames.com/*/themes/Arc/js/custom.js
    
    ​​

    GAME FORUMS (Direct Link & Arc Frame)
    Hub | Arc | PWI | FW | NW | STO | SO | BLR | JD | BOI | CO | WOI
    Hub | Arc | PWI | FW | NW | STO | SO | BLR | JD | BOI | CO | WOI
    Forum Enhancements and Visual Improvements
    (Greasemonkey/Tampermonkey and/or Stylish required)
    PWI vBulletin Forum Data Dumps and Backups
  • dabelgravedabelgrave Posts: 83 Arc User
    edited November 2015
    nrglg wrote: »
    For anyone who wants, this should block the new custom.js and embed.js redirection for all of the sites and anything within it.
    *forum.arcgames.com/*/js/embed.js
    *forum.arcgames.com/*/themes/Arc/js/custom.js
    
    Thanks, that makes the forums useable again.
    :)

    Edit: Until I try coming back to this thread, and it no longer works until I turn those off.​​
    Post edited by dabelgrave on
  • khamseenairkhamseenair Posts: 345 Arc User
    nrglg wrote: »
    For anyone who wants, this should block the new custom.js and embed.js redirection for all of the sites and anything within it.
    *forum.arcgames.com/*/js/embed.js
    *forum.arcgames.com/*/themes/Arc/js/custom.js
    

    Thanks man, that saves having to list them all in my adblock independently.

    I asked Trendy about this over on the STO forums and this was her response.
    I cannot fully comment on the why, but simply that it's necessary due to the Vanilla structure for security. :S
    ​​
    <center>Ciaran%20Sig.jpg
    Join date is wrong, I've actually been around since STO Beta.
    True alters don't have a "main". Account wide unlocks for all unique event rewards!!
    Check my GitHub for details on STO forum themes: https://github.com/khamseen/PWEVan
    Get the Forums Enhancement Extension!</center>
  • nrglgnrglg Posts: 347 Arc User
    Sorry to say, but that explanation from trendy is nothing but half-assed. I used to work in the security field and I can guarantee that the embedded version is not providing extra security in any way, shape, or form. The only thing it does is maybe hash some user data tidbit and generate a key which is used to log in to the forums when using the framed version. However, once this has been done once, and assuming you don't clear the cookies, it is kept logged in for some time before needing to do it over again.​​

    GAME FORUMS (Direct Link & Arc Frame)
    Hub | Arc | PWI | FW | NW | STO | SO | BLR | JD | BOI | CO | WOI
    Hub | Arc | PWI | FW | NW | STO | SO | BLR | JD | BOI | CO | WOI
    Forum Enhancements and Visual Improvements
    (Greasemonkey/Tampermonkey and/or Stylish required)
    PWI vBulletin Forum Data Dumps and Backups
  • khamseenairkhamseenair Posts: 345 Arc User
    I completely agree with you on that. In no way do I believe this redirect is in any way vital to our "security", I just thought I'd post it here since it's the only kind of official response I've ever actually seen about why they are forcing these annoying redirects on us. ​​
    <center>Ciaran%20Sig.jpg
    Join date is wrong, I've actually been around since STO Beta.
    True alters don't have a "main". Account wide unlocks for all unique event rewards!!
    Check my GitHub for details on STO forum themes: https://github.com/khamseen/PWEVan
    Get the Forums Enhancement Extension!</center>
  • nunoespadinha#0711 nunoespadinha Posts: 2 Arc User
    edited January 2016
    Just changed it yesterday, looks amazing!!
    I have two questions!!
    *Is there a way to fix the background and make only the messages scroll up and down?
    *Is there a way of making the "leave this page / stay on this page" pop up stopping to show?

    oh... and now the signature settings says "Images not allowed" :(​​
  • sylenthundersylenthunder Posts: 256 Community Moderator
    To stop the leave/stay message....
    nrglg wrote: »
    I've never seen a place this hell-bent on redirecting users to a slower and more resource consuming iframe version of their forums. I just don't understand the obsession.

    For anyone who wants, this should block the new custom.js and embed.js redirection for all of the sites and anything within it.
    *forum.arcgames.com/*/js/embed.js
    *forum.arcgames.com/*/themes/Arc/js/custom.js
    

    Which theme are you using? the background is static on most of the ones I've tried.​​
  • sylenthundersylenthunder Posts: 256 Community Moderator
    edited February 2016
    Any ideas why fluid width is no longer working for me?

    Also, a while ago I started using the embed so I can perform proper Mod stuffs, and now cannot get rid of the embed no matter how I try. I was attempting to do this to troubleshoot, but now I'm stuck with it either way.

    Edit again: Finally got it to work without the embed, and now fluid width is working again. Any ideas on how to get it working again with the embed? It was fine until a few days ago.​​
    Post edited by sylenthunder on
  • sylenthundersylenthunder Posts: 256 Community Moderator
    Dangit, now I cannot edit the previous post. Now it's not working again on the forumarcgames.com sites without the embed.

    This is going to drive me absolutely nuts. One minute it works, the next it doesn't.​​
  • khamseenairkhamseenair Posts: 345 Arc User
    edited February 2016
    They appear to have made yet more changes to the base CSS. Part of that is they've added a max-width:1200px; to the .row element which is why it's preventing the fluid width from stretching out the same as it used to. Will have to go through fixing themes again.

    Edit: Uploaded some fixes to the STO Fed theme. More changes may be inbound if I find any other things they've changed.
    ​​
    <center>Ciaran%20Sig.jpg
    Join date is wrong, I've actually been around since STO Beta.
    True alters don't have a "main". Account wide unlocks for all unique event rewards!!
    Check my GitHub for details on STO forum themes: https://github.com/khamseen/PWEVan
    Get the Forums Enhancement Extension!</center>
  • ediraedira Posts: 32 Arc User
    What happened, going to sleep, waking up and now I'm stuck with the standard forum skin? I'll assume it's not just a problem with my browser/machine since it is the same with my notebook.​​
    Forsaken World - Server: Dyos - Kindred Fire Mage
  • sylenthundersylenthunder Posts: 256 Community Moderator
    edira said:

    What happened, going to sleep, waking up and now I'm stuck with the standard forum skin? I'll assume it's not just a problem with my browser/machine since it is the same with my notebook.​​

    No, something happened. I cannot even change themes atm. Not sure what it was, but it's not pretty.

    I know PWE is supposed to be rolling out some changes to the forums soon, so it's probably some change they made that's broken the enhancement.
  • catgirldesucatgirldesu Posts: 24 Arc User
    It seems to be working again... for now.
    I've been getting a lot of problems since earlier today, though. White background, broken enhancements features, options being all over the place, having to disable AdBlock (I use it to bypass that thing that makes you load forums for ages) just to view the forums.
    ​​
  • sylenthundersylenthunder Posts: 256 Community Moderator
    I still have the white background. I temporarily turned off the enhancements for some testing, so it looks like PWE removed the default background images they had. I may play with the code this weekend, but I can't today. I'm totally fried.
  • hogwarts123hogwarts123 Posts: 1 Arc User
    Hey guys, I am having problems with the java file. It is saying that the "document is undefined" when I try to run it any ideas?
  • dabelgravedabelgrave Posts: 83 Arc User
    edited August 2016
    I'm trying to get this on a fresh browser copy, but it keeps giving an error:

    Download Error
    Could not parse script:
    Ignoring @match pattern htt*://forum.arcgames.com/* because:
    Error: @match: Could not parse the pattern.

    It still works on browsers where I already had it installed, but I don't think it's updating itself.
  • smeeinn1tsmeeinn1t Posts: 66 Arc User
    dabelgrave wrote: »
    I'm trying to get this on a fresh browser copy, but it keeps giving an error:

    Download Error
    Could not parse script:
    Ignoring @match pattern htt*://forum.arcgames.com/* because:
    Error: @match: Could not parse the pattern.

    It still works on browsers where I already had it installed, but I don't think it's updating itself.

    I have the same issue, just set up new PC.
    V9BQ6SM.gif
    "A human being should be able to change a diaper, plan an invasion, butcher a hog, conn a ship, design a building, write a sonnet, balance accounts, build a wall, set a bone, comfort the dying, take orders, give orders, cooperate, act alone, solve equations, analyze a new problem, pitch manure, program a computer, cook a tasty meal, fight efficiently, die gallantly. Specialization is for insects." — Lazarus Long [font="title-Space Cadet ☮"][/font]Get the Forums Enhancement Extension!
Sign In or Register to comment.